summaryrefslogtreecommitdiff
path: root/app-arch/dpkg
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/dpkg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/Manifest3
-rw-r--r--app-arch/dpkg/dpkg-1.17.25.ebuild98
-rw-r--r--app-arch/dpkg/dpkg-1.18.1.ebuild98
-rw-r--r--app-arch/dpkg/dpkg-1.18.2.ebuild98
-rw-r--r--app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch11
-rw-r--r--app-arch/dpkg/files/dpkg-1.17.1-flags.patch11
-rw-r--r--app-arch/dpkg/metadata.xml8
7 files changed, 327 insertions, 0 deletions
diff --git a/app-arch/dpkg/Manifest b/app-arch/dpkg/Manifest
new file mode 100644
index 00000000000..9b1fabffa08
--- /dev/null
+++ b/app-arch/dpkg/Manifest
@@ -0,0 +1,3 @@
+DIST dpkg_1.17.25.tar.xz 4407792 SHA256 07019d38ae98fb107c79dbb3690cfadff877f153b8c4970e3a30d2e59aa66baa SHA512 6a4b45c0f59cd11fc104d954ab790dd7e11e650cd6dde303a664023a04bf6fbc49c878eaf00e27dd7f9bf5e79a92b3a5f5923d003942436758a3027364a0b7c7 WHIRLPOOL 6ed2d8a645787a83f431803214cce9b1c7516c4083ffe651deb7c2f8b641b85d3a17271030286155a985dfd0046fbd584d2d750ab8954e8e5af74085d7651bd2
+DIST dpkg_1.18.1.tar.xz 4340240 SHA256 cb26a97ca21c970cbe63a762125fe21f7437663badf6ce686589fe62650399da SHA512 1aa6b3e5300f80382d84c5f74d945863ea4bc4e71774d6798552421f26cd258b9b96cced1f65b8fca4995c96e2fa55dfb340aa7e1bb8a9f35c74a9fef8dcf0ba WHIRLPOOL 368d3c4e5639f46e0eca572dbcd29800ad4b2f6dadec812065abb0ffacd9846aec26d51f6f386770daa284a91ddd55734bdc9e8db4932df8ea3d0056c5da7839
+DIST dpkg_1.18.2.tar.xz 4345224 SHA256 11484f2a73d027d696e720a60380db71978bb5c06cd88fe30c291e069ac457a4 SHA512 cd84ba53a0a8d6f8c9a79d1b3e4c7716249e6dbf8b92635f4691cc31c9896bc156f6ea5a42de419210133497d05c41eb00208b3ec02d44a177015d23873003af WHIRLPOOL 2f4a60e8127c3514ba9ee51723e4057724b8b8a99caea6812d80bca5617cd6f3971a80c219162fd16059e08bd0914d15a39e618fd115bb6dcb8a6b402c64be42
diff --git a/app-arch/dpkg/dpkg-1.17.25.ebuild b/app-arch/dpkg/dpkg-1.17.25.ebuild
new file mode 100644
index 00000000000..369cfc9ace6
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.17.25.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.0:=
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ selinux? ( sys-libs/libselinux )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+
+DOCS=( ChangeLog THANKS TODO )
+
+src_prepare() {
+ # do not expect Debian's gzip --rsyncable extension
+ epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
+
+ epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ if [[ ${CHOST} == mips64*-linux-gnu ]] ; then
+ # Debian targets use custom full tuples. Map the default one
+ # based on the ABI we're using.
+ local abi
+ if [[ ${ABI} == "n64" ]] ; then
+ abi="mips64"
+ else
+ abi="mipsn32"
+ fi
+ printf "gnu-linux-mips64 ${abi}\ngnu-linux-mips64el ${abi}el\n" >> triplettable
+ fi
+
+ use nls && strip-linguas -i po
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 bz2) \
+ $(use_with lzma liblzma) \
+ $(use_with selinux) \
+ $(use_with zlib) \
+ --disable-compiler-warnings \
+ --disable-dselect \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}
diff --git a/app-arch/dpkg/dpkg-1.18.1.ebuild b/app-arch/dpkg/dpkg-1.18.1.ebuild
new file mode 100644
index 00000000000..808e52f6014
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.18.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.0:=
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ selinux? ( sys-libs/libselinux )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+
+DOCS=( ChangeLog THANKS TODO )
+
+src_prepare() {
+ # do not expect Debian's gzip --rsyncable extension
+ epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
+
+ epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ if [[ ${CHOST} == mips64*-linux-gnu ]] ; then
+ # Debian targets use custom full tuples. Map the default one
+ # based on the ABI we're using.
+ local abi
+ if [[ ${ABI} == "n64" ]] ; then
+ abi="mips64"
+ else
+ abi="mipsn32"
+ fi
+ printf "gnu-linux-mips64 ${abi}\ngnu-linux-mips64el ${abi}el\n" >> triplettable
+ fi
+
+ use nls && strip-linguas -i po
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 bz2) \
+ $(use_with lzma liblzma) \
+ $(use_with selinux) \
+ $(use_with zlib) \
+ --disable-compiler-warnings \
+ --disable-dselect \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}
diff --git a/app-arch/dpkg/dpkg-1.18.2.ebuild b/app-arch/dpkg/dpkg-1.18.2.ebuild
new file mode 100644
index 00000000000..808e52f6014
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.18.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.0:=
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ selinux? ( sys-libs/libselinux )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+
+DOCS=( ChangeLog THANKS TODO )
+
+src_prepare() {
+ # do not expect Debian's gzip --rsyncable extension
+ epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
+
+ epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ if [[ ${CHOST} == mips64*-linux-gnu ]] ; then
+ # Debian targets use custom full tuples. Map the default one
+ # based on the ABI we're using.
+ local abi
+ if [[ ${ABI} == "n64" ]] ; then
+ abi="mips64"
+ else
+ abi="mipsn32"
+ fi
+ printf "gnu-linux-mips64 ${abi}\ngnu-linux-mips64el ${abi}el\n" >> triplettable
+ fi
+
+ use nls && strip-linguas -i po
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 bz2) \
+ $(use_with lzma liblzma) \
+ $(use_with selinux) \
+ $(use_with zlib) \
+ --disable-compiler-warnings \
+ --disable-dselect \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}
diff --git a/app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch b/app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch
new file mode 100644
index 00000000000..f956ca590ce
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch
@@ -0,0 +1,11 @@
+--- a/scripts/Dpkg/Compression.pm
++++ b/scripts/Dpkg/Compression.pm
+@@ -52,7 +52,7 @@
+ my $COMP = {
+ gzip => {
+ file_ext => 'gz',
+- comp_prog => [ 'gzip', '--no-name', '--rsyncable' ],
++ comp_prog => [ 'gzip', '--no-name' ],
+ decomp_prog => [ 'gunzip' ],
+ default_level => 9,
+ },
diff --git a/app-arch/dpkg/files/dpkg-1.17.1-flags.patch b/app-arch/dpkg/files/dpkg-1.17.1-flags.patch
new file mode 100644
index 00000000000..9517714fa41
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.17.1-flags.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -104,8 +104,6 @@
+ # Checks for the build machinery.
+ AC_DEFINE(LIBDPKG_VOLATILE_API, 1, [Acknowledge the volatility of the API.])
+ DPKG_COMPILER_WARNINGS
+-DPKG_COMPILER_OPTIMISATIONS
+-DPKG_LINKER_OPTIMISATIONS
+ DPKG_ARCHITECTURE
+
+ AC_CONFIG_FILES([ Makefile
diff --git a/app-arch/dpkg/metadata.xml b/app-arch/dpkg/metadata.xml
new file mode 100644
index 00000000000..2d74819279d
--- /dev/null
+++ b/app-arch/dpkg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>deb-tools</herd>
+<use>
+<flag name="update-alternatives">Install update-alternatives</flag>
+</use>
+</pkgmetadata>