summaryrefslogtreecommitdiff
path: root/app-arch/dump/dump-0.4.44-r1.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/dump/dump-0.4.44-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/dump/dump-0.4.44-r1.ebuild')
-rw-r--r--app-arch/dump/dump-0.4.44-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-arch/dump/dump-0.4.44-r1.ebuild b/app-arch/dump/dump-0.4.44-r1.ebuild
new file mode 100644
index 00000000000..641d0475eee
--- /dev/null
+++ b/app-arch/dump/dump-0.4.44-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils autotools
+
+MY_P=${P/4./4b}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+HOMEPAGE="http://dump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86"
+IUSE="debug ermt readline selinux static"
+
+RDEPEND=">=sys-fs/e2fsprogs-1.27
+ >=app-arch/bzip2-1.0.2
+ >=sys-libs/zlib-1.1.4
+ ermt? ( dev-libs/openssl )
+ readline? ( sys-libs/readline
+ sys-libs/ncurses
+ static? ( sys-libs/ncurses[static-libs] ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ virtual/os-headers"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-underlinking.patch"
+ epatch "${FILESDIR}/${P}-rl_completion_matches-detection.patch"
+ epatch "${FILESDIR}/${P}-fix-pointers-aliasing.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-dumpdatespath=/etc/dumpdates \
+ --with-{bin,man}owner=root \
+ --with-{bin,man}grp=root \
+ --enable-largefile \
+ $(use_enable selinux transselinux) \
+ $(use_enable ermt) \
+ $(use_enable static) \
+ $(use_enable readline) \
+ $(use_enable debug)
+}
+
+src_install() {
+ # built on old autotools, no DESTDIR support
+ einstall MANDIR="${D}"/usr/share/man/man8
+ mv "${ED}"/usr/sbin/{,dump-}rmt || die
+ mv "${ED}"/usr/share/man/man8/{,dump-}rmt.8 || die
+ use ermt && newsbin rmt/ermt dump-ermt
+
+ dodoc CHANGES KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
+ dodoc -r examples/*
+}
+
+pkg_postinst() {
+ ewarn "app-arch/dump installs 'rmt' as 'dump-rmt'."
+ ewarn "This is to avoid conflicts with app-arch/tar 'rmt'."
+}