summaryrefslogtreecommitdiff
path: root/app-arch/dump
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-05-09 02:40:47 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-09 02:40:51 -0400
commit323e36c233ce121f2deff9a5c4169e9cf2a2d799 (patch)
tree446839a2344c87330f90acd688ba91710f6f65eb /app-arch/dump
parentfbb223854e0af123c98f996f00b10f065c1bda02 (diff)
downloadgentoo-323e36c233ce121f2deff9a5c4169e9cf2a2d799.tar.gz
gentoo-323e36c233ce121f2deff9a5c4169e9cf2a2d799.tar.xz
app-arch/dump: version bump to 0.4.45
Diffstat (limited to 'app-arch/dump')
-rw-r--r--app-arch/dump/Manifest1
-rw-r--r--app-arch/dump/dump-0.4.45.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-arch/dump/Manifest b/app-arch/dump/Manifest
index 8c184d0f445..a1e10564af5 100644
--- a/app-arch/dump/Manifest
+++ b/app-arch/dump/Manifest
@@ -1 +1,2 @@
DIST dump-0.4b44.tar.gz 296691 SHA256 78cb75632ac5e99dca38af3a2574303eee3c5a7af464011d279421d8b0e64f96 SHA512 3db828bac026d872913f0e010378366919fbb523d22f1863c06017581e4f4a1c5a239199794ca1158b04e7e3ecbb596d77b131b3278bed29fcfcd3835a3351d4 WHIRLPOOL 43dfc8fb996b443b9d9a9d9ecbf7d01f3db6eaba7acc92ab35ee0930ebdc7666855fc6b78b25450ae3790c6f10093036e0fc733385d7e8dc808bb614b681135a
+DIST dump-0.4b45.tar.gz 579802 SHA256 f2feef14e9b764f8763879f044957564926f493a5ecd69cefa79a258c1e66c8a SHA512 8bb961cfbec7b06a0a796c15e35342b694a0a5e4214be6b0093a3b016340bce8d76b86cad64ca80301a3cbaebb7ec23b32c5145069f793266f4f8c60d98933cf WHIRLPOOL 0b8beb09bf0c9ddd9399f25a989117759ef6ec578a148897de14904292885cf9a30e0a8d1f0cd2bdab852fac3653f43d26393236260568f11c16813d4f27b5ce
diff --git a/app-arch/dump/dump-0.4.45.ebuild b/app-arch/dump/dump-0.4.45.ebuild
new file mode 100644
index 00000000000..c8b7cecb788
--- /dev/null
+++ b/app-arch/dump/dump-0.4.45.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+MY_P=${P/4./4b}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+HOMEPAGE="http://dump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bzip2 debug ermt libressl lzo readline selinux sqlite ssl static zlib"
+REQUIRED_USE="
+ ermt? ( ssl )
+ ssl? ( zlib )
+"
+
+RDEPEND=">=sys-fs/e2fsprogs-1.27:=
+ >=sys-libs/e2fsprogs-libs-1.27:=
+ sys-apps/util-linux
+ bzip2? ( >=app-arch/bzip2-1.0.2:= )
+ zlib? ( >=sys-libs/zlib-1.1.4:= )
+ lzo? ( dev-libs/lzo:2= )
+ sqlite? ( dev-db/sqlite:3= )
+ ermt? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ readline? (
+ sys-libs/readline:0=
+ sys-libs/ncurses:=
+ static? ( sys-libs/ncurses:=[static-libs] )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ virtual/os-headers"
+
+src_configure() {
+ econf \
+ --with-dumpdatespath=/etc/dumpdates \
+ --with-rmtpath='$(sbindir)/rmt' \
+ --enable-blkid \
+ --disable-uuid \
+ $(use_enable selinux) \
+ $(use_enable ermt) \
+ $(use_enable static static-progs) \
+ $(use_enable readline) \
+ $(use_enable debug) \
+ $(use_enable sqlite) \
+ $(use_enable bzip2) \
+ $(use_enable zlib) \
+ $(use_enable lzo) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/sbin/{,dump-}rmt || die
+ mv "${ED}"/usr/share/man/man8/{,dump-}rmt.8 || die
+ use ermt && newsbin rmt/ermt dump-ermt
+
+ dodoc KNOWNBUGS MAINTAINERS REPORTING-BUGS
+ dodoc -r examples
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ ewarn "app-arch/dump installs 'rmt' as 'dump-rmt'."
+ ewarn "This is to avoid conflicts with app-arch/tar 'rmt'."
+ fi
+}