summaryrefslogtreecommitdiff
path: root/app-arch/p7zip
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-07-24 18:57:03 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2016-07-25 17:40:34 -0500
commit6793838e850e22d03a9c3cc33da21b919968f9e7 (patch)
tree09b49251c8642e015454a50b71388de0eb48e262 /app-arch/p7zip
parent56c2a875e44e938015ea92ed1df760f51b90bf7c (diff)
downloadgentoo-6793838e850e22d03a9c3cc33da21b919968f9e7.tar.gz
gentoo-6793838e850e22d03a9c3cc33da21b919968f9e7.tar.xz
app-arch/p7zip: Drop kdelibs (R)DEPEND, sort DEPEND/IUSE, EAPI=6
kde-base/kdelibs:4 is not required here as p7zip only (manually) installs a bunch of desktop files that may or may not be picked up by applications. wxGTK[X] is already enforced by REQUIRED_USE, so there is no reason to duplicate that. Reversed symlink logic for ServiceMenu as kservices5 is here to stay and kde4/services is deprecated. Package-Manager: portage-2.2.28 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-arch/p7zip')
-rw-r--r--app-arch/p7zip/files/p7zip-16.02-darwin.patch4
-rw-r--r--app-arch/p7zip/p7zip-16.02-r1.ebuild (renamed from app-arch/p7zip/p7zip-16.02.ebuild)25
2 files changed, 15 insertions, 14 deletions
diff --git a/app-arch/p7zip/files/p7zip-16.02-darwin.patch b/app-arch/p7zip/files/p7zip-16.02-darwin.patch
index e7f40f50528..1ee5d3434b9 100644
--- a/app-arch/p7zip/files/p7zip-16.02-darwin.patch
+++ b/app-arch/p7zip/files/p7zip-16.02-darwin.patch
@@ -1,5 +1,5 @@
---- p7zip_15.14.1/CPP/myWindows/StdAfx.h
-+++ p7zip_15.14.1/CPP/myWindows/StdAfx.h
+--- a/CPP/myWindows/StdAfx.h
++++ b/CPP/myWindows/StdAfx.h
@@ -32,7 +32,7 @@
#include <errno.h>
#include <math.h>
diff --git a/app-arch/p7zip/p7zip-16.02.ebuild b/app-arch/p7zip/p7zip-16.02-r1.ebuild
index c34eb8600d0..dd37e65a3fd 100644
--- a/app-arch/p7zip/p7zip-16.02.ebuild
+++ b/app-arch/p7zip/p7zip-16.02-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
WX_GTK_VER="3.0"
@@ -15,22 +15,24 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
LICENSE="LGPL-2.1 rar? ( unRAR )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="doc kde rar +pch static wxwidgets abi_x86_x32"
+IUSE="abi_x86_x32 doc kde +pch rar static wxwidgets"
REQUIRED_USE="kde? ( wxwidgets )"
-RDEPEND="
- kde? ( x11-libs/wxGTK:${WX_GTK_VER}[X] kde-base/kdelibs )
- wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )"
+RDEPEND="wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )"
DEPEND="${RDEPEND}
- amd64? ( dev-lang/yasm )
abi_x86_x32? ( >=dev-lang/yasm-1.2.0-r1 )
+ amd64? ( dev-lang/yasm )
x86? ( dev-lang/nasm )"
S=${WORKDIR}/${PN}_${PV}
+DOCS=( ChangeLog README TODO )
+
+PATCHES=( "${FILESDIR}"/${P}-darwin.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-darwin.patch
+ default
if ! use pch; then
sed "s:PRE_COMPILED_HEADER=StdAfx.h.gch:PRE_COMPILED_HEADER=:g" -i makefile.* || die
@@ -128,12 +130,12 @@ src_install() {
if use kde; then
rm GUI/kde4/p7zip_compress.desktop || die
- insinto /usr/share/kde4/services/ServiceMenus
+ insinto /usr/share/kservices5/ServiceMenus
doins GUI/kde4/*.desktop
- dodir /usr/share/kservices5/ServiceMenus
- for item in "${D}"/usr/share/kde4/services/ServiceMenus/*.desktop; do
+ dodir /usr/share/kde4/services/ServiceMenus # drop these lines after konqueror:4/krusader:4 are gone
+ for item in "${ED}"usr/share/kservices5/ServiceMenus/*.desktop; do
item="$(basename ${item})"
- dosym "/usr/share/kde4/services/ServiceMenus/${item}" "/usr/share/kservices5/ServiceMenus/${item}"
+ dosym "/usr/share/kservices5/ServiceMenus/${item}" "/usr/share/kde4/services/ServiceMenus/${item}"
done
fi
fi
@@ -150,7 +152,6 @@ src_install() {
fi
doman man1/7z.1 man1/7za.1 man1/7zr.1
- dodoc ChangeLog README TODO
if use doc; then
dodoc DOC/*.txt