summaryrefslogtreecommitdiff
path: root/app-arch/pdlzip/pdlzip-1.7.ebuild
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-05-25 15:16:18 +0200
committerMichał Górny <mgorny@gentoo.org>2016-05-25 15:16:50 +0200
commit438223d58c0df22a3b58a2c1d89497a87ae87c79 (patch)
tree4c42d2e9ee2dfd1ed2299a38b843685296272f53 /app-arch/pdlzip/pdlzip-1.7.ebuild
parent5953c9d3374377573be86446c4d835eb04b8a168 (diff)
downloadgentoo-438223d58c0df22a3b58a2c1d89497a87ae87c79.tar.gz
gentoo-438223d58c0df22a3b58a2c1d89497a87ae87c79.tar.xz
app-arch/pdlzip: Bump to 1.7
Diffstat (limited to 'app-arch/pdlzip/pdlzip-1.7.ebuild')
-rw-r--r--app-arch/pdlzip/pdlzip-1.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/pdlzip/pdlzip-1.7.ebuild b/app-arch/pdlzip/pdlzip-1.7.ebuild
new file mode 100644
index 00000000000..4c1b4e464d3
--- /dev/null
+++ b/app-arch/pdlzip/pdlzip-1.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Public-domain version of lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/pdlzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/pdlzip/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}