summaryrefslogtreecommitdiff
path: root/app-arch/pdv
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/pdv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/pdv')
-rw-r--r--app-arch/pdv/Manifest1
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-default-args.patch16
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-early-free.patch21
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-no-strip.patch13
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-opt.patch24
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-x-config.patch18
-rw-r--r--app-arch/pdv/metadata.xml12
-rw-r--r--app-arch/pdv/pdv-1.5.1-r2.ebuild57
8 files changed, 162 insertions, 0 deletions
diff --git a/app-arch/pdv/Manifest b/app-arch/pdv/Manifest
new file mode 100644
index 00000000000..44a231cbb61
--- /dev/null
+++ b/app-arch/pdv/Manifest
@@ -0,0 +1 @@
+DIST pdv-1.5.1.tar.gz 87858 SHA256 1c941a571e1f60b903b4b8e5154f1321d32cd593118c9f399e3fed4561a1b1ad SHA512 c8db9aa4c29016474d33111e8343174a1fb25f152517bceb29428def5e02590b1de523ffcf2c0f6ffbaec5b357e3893f48188775c2e66d343a21e04343b1d0e9 WHIRLPOOL f114691b60e80c598eeff6dcf3388670d13ba448ed893b5de6ea0a8a0a31afff993cef0b90fc84ccfeb944c8333accf05d8e6720668b62104c252c7388d7b410
diff --git a/app-arch/pdv/files/pdv-1.5.1-default-args.patch b/app-arch/pdv/files/pdv-1.5.1-default-args.patch
new file mode 100644
index 00000000000..dc61def911f
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-default-args.patch
@@ -0,0 +1,16 @@
+diff -ur pdv-1.5.1.orig/pdv.h pdv-1.5.1/pdv.h
+--- pdv-1.5.1.orig/pdv.h 2001-09-01 12:09:28.000000000 -0700
++++ pdv-1.5.1/pdv.h 2006-07-22 22:20:43.000000000 -0700
+@@ -47,9 +47,9 @@
+ char *cmd; /* command to execute after delivery */
+ char *hlpmsg; /* user help message */
+ char *agrmsg; /* optional agreement message */
+- char iscompressed; /* filter payload through uncompress */
+- char isatar; /* filter payload through tar */
+- char iszipped; /* use internal compression library */
++ signed char iscompressed; /* filter payload through uncompress */
++ signed char isatar; /* filter payload through tar */
++ signed char iszipped; /* use internal compression library */
+ off_t payloadstart; /* start of payload (after pdv stub) */
+ off_t metadatastart; /* start of payload data (at end of file) */
+ };
diff --git a/app-arch/pdv/files/pdv-1.5.1-early-free.patch b/app-arch/pdv/files/pdv-1.5.1-early-free.patch
new file mode 100644
index 00000000000..6896d9437f4
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-early-free.patch
@@ -0,0 +1,21 @@
+diff -ur pdv-1.5.1-orig/mkpkgutils.c pdv-1.5.1/mkpkgutils.c
+--- pdv-1.5.1-orig/mkpkgutils.c 2005-04-26 15:01:30.525131384 -0700
++++ pdv-1.5.1/mkpkgutils.c 2005-04-26 15:55:19.004327944 -0700
+@@ -114,8 +114,6 @@
+ if(access(fn_tst, R_OK) == 0)
+ fn = strdup(fn_tst);
+
+- free(fn_tst);
+-
+ /* if we could not find it then try the search path
+ including the current directory as a last resort */
+
+@@ -144,6 +142,8 @@
+ free(path);
+ } /* if(fn == NULL) */
+
++ free(fn_tst);
++
+ return fn;
+ } /* findpdv */
+
diff --git a/app-arch/pdv/files/pdv-1.5.1-no-strip.patch b/app-arch/pdv/files/pdv-1.5.1-no-strip.patch
new file mode 100644
index 00000000000..630bf5eb7c3
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-no-strip.patch
@@ -0,0 +1,13 @@
+diff -ur pdv-1.5.1-orig/pdv.c pdv-1.5.1/pdv.c
+--- pdv-1.5.1-orig/Makefile.in 2008-12-06 23:17:46.000000000 -0800
++++ pdv-1.5.1/Makefile.in 2008-12-06 23:18:37.000000000 -0800
+@@ -536,7 +536,8 @@
+ touch $@
+
+ pdv_fixed : pdv_fixed.c pdv
+- $(STRIPBIN) pdv
++ # let portage decide whether to strip binaries
++ #$(STRIPBIN) pdv
+ printf "%-5.5s" $$VERSION >> pdv
+ printf "\000\000\000\000\000\000\000\000" >> pdv
+ sleep 1
diff --git a/app-arch/pdv/files/pdv-1.5.1-opt.patch b/app-arch/pdv/files/pdv-1.5.1-opt.patch
new file mode 100644
index 00000000000..df3ebb1b669
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-opt.patch
@@ -0,0 +1,24 @@
+diff -ur pdv-1.5.1-orig/pdv.c pdv-1.5.1/pdv.c
+--- pdv-1.5.1-orig/pdv.c 2005-04-24 19:27:15.705946000 -0700
++++ pdv-1.5.1/pdv.c 2005-04-24 19:17:27.042436456 -0700
+@@ -79,7 +79,7 @@
+ int
+ main(int argc, char *argv[])
+ {
+- char opt;
++ int opt;
+ int retval = 0;
+ int showhelp = 0;
+ struct payload_st pld_data;
+diff -ur pdv-1.5.1-orig/pdvmkpkg.c pdv-1.5.1/pdvmkpkg.c
+--- pdv-1.5.1-orig/pdvmkpkg.c 2005-04-24 19:27:28.680973496 -0700
++++ pdv-1.5.1/pdvmkpkg.c 2005-04-24 19:21:49.992461976 -0700
+@@ -94,7 +94,7 @@
+ int promptusr = 0;
+ int nopts = 0;
+ int result;
+- char opt;
++ int opt;
+ struct stat payldstat;
+ struct payload_st pld_data;
+ struct pdvspec_st spec;
diff --git a/app-arch/pdv/files/pdv-1.5.1-x-config.patch b/app-arch/pdv/files/pdv-1.5.1-x-config.patch
new file mode 100644
index 00000000000..8bab9bee1bf
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-x-config.patch
@@ -0,0 +1,18 @@
+diff -ur pdv-1.5.1-orig/X11/configure.in pdv-1.5.1/X11/configure.in
+--- pdv-1.5.1-orig/X11/configure.in 2005-05-13 13:43:27.577544136 -0700
++++ pdv-1.5.1/X11/configure.in 2005-05-13 13:36:14.218424736 -0700
+@@ -17,8 +17,12 @@
+ AC_PATH_X
+
+ dnl Checks for libraries.
+-CFLAGS=-I$x_includes
+-LDFLAGS=-L$x_libraries
++if test "x$x_includes" != x ; then
++ CFLAGS="$CFLAGS -I$x_includes"
++fi
++if test "x$x_libraries" != x ; then
++ LDFLAGS="$LDFLAGS -L$x_libraries"
++fi
+
+ AC_CHECK_LIB(Xt, XtManageChild)
+ AC_CHECK_LIB(X11, XLoadFont)
diff --git a/app-arch/pdv/metadata.xml b/app-arch/pdv/metadata.xml
new file mode 100644
index 00000000000..ed5703f6dbb
--- /dev/null
+++ b/app-arch/pdv/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>A payload Delivery vehicle that contains a complete package and
+the commands to install it.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pdv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/pdv/pdv-1.5.1-r2.ebuild b/app-arch/pdv/pdv-1.5.1-r2.ebuild
new file mode 100644
index 00000000000..2c7bb565e95
--- /dev/null
+++ b/app-arch/pdv/pdv-1.5.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools toolchain-funcs
+
+DESCRIPTION="build a self-extracting and self-installing binary package"
+HOMEPAGE="http://sourceforge.net/projects/pdv"
+SRC_URI="mirror://sourceforge/pdv/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ppc x86 ~x86-linux ~ppc-macos"
+IUSE="X"
+
+DEPEND="X? ( >=x11-libs/motif-2.3:0
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libXext-1.0.0
+ >=x11-libs/libXp-1.0.0 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix a size-of-variable bug
+ epatch "${FILESDIR}"/${P}-opt.patch
+ # fix a free-before-use bug
+ epatch "${FILESDIR}"/${P}-early-free.patch
+ # fix a configure script bug
+ epatch "${FILESDIR}"/${P}-x-config.patch
+ # fix default args bug from assuming 'char' is signed
+ epatch "${FILESDIR}"/${P}-default-args.patch
+ # prevent pre-stripped binaries
+ epatch "${FILESDIR}"/${P}-no-strip.patch
+
+ # re-build configure script since patch was applied to configure.in
+ cd "${S}"/X11
+ eautoreconf
+ tc-export CC
+}
+
+src_configure() {
+ local myconf=""
+ use X || myconf="--without-x" # configure script is broken, cant use use_with
+ econf ${myconf}
+}
+
+src_install() {
+ dobin pdv pdvmkpkg
+ doman pdv.1 pdvmkpkg.1
+ if use X ; then
+ dobin X11/xmpdvmkpkg
+ doman xmpdvmkpkg.1
+ fi
+ dodoc AUTHORS ChangeLog NEWS README pdv.lsm
+}