summaryrefslogtreecommitdiff
path: root/app-arch/pigz/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/pigz/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/pigz/files')
-rw-r--r--app-arch/pigz/files/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch47
-rw-r--r--app-arch/pigz/files/pigz-2.3-make.patch25
-rw-r--r--app-arch/pigz/files/pigz-2.3.3-ldflags.patch34
3 files changed, 106 insertions, 0 deletions
diff --git a/app-arch/pigz/files/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch b/app-arch/pigz/files/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch
new file mode 100644
index 00000000000..9d2512e055a
--- /dev/null
+++ b/app-arch/pigz/files/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch
@@ -0,0 +1,47 @@
+From 0c967f989d2f1afe1829cf7cf2f6d36846a625ec Mon Sep 17 00:00:00 2001
+From: Mark Adler <madler@alumni.caltech.edu>
+Date: Sun, 19 Jan 2014 23:21:58 -0800
+Subject: [PATCH] Do not return non-zero exit code when warnings issued.
+
+---
+ pigz.c | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/pigz.c b/pigz.c
+index 4fefe40..4a16799 100644
+--- a/pigz.c
++++ b/pigz.c
+@@ -478,7 +478,6 @@ local struct {
+ int procs; /* maximum number of compression threads (>= 1) */
+ int setdict; /* true to initialize dictionary in each thread */
+ size_t block; /* uncompressed input size per thread (>= 32K) */
+- int warned; /* true if a warning has been given */
+
+ /* saved gzip/zip header data for decompression, testing, and listing */
+ time_t stamp; /* time stamp from gzip header */
+@@ -519,7 +518,6 @@ local int complain(char *fmt, ...)
+ va_end(ap);
+ putc('\n', stderr);
+ fflush(stderr);
+- g.warned = 1;
+ }
+ return 0;
+ }
+@@ -3929,7 +3927,6 @@ int main(int argc, char **argv)
+ /* initialize globals */
+ g.outf = NULL;
+ g.first = 1;
+- g.warned = 0;
+ g.hname = NULL;
+
+ /* save pointer to program name for error messages */
+@@ -4020,5 +4017,5 @@ int main(int argc, char **argv)
+ /* done -- release resources, show log */
+ new_opts();
+ log_dump();
+- return g.warned ? 2 : 0;
++ return 0;
+ }
+--
+1.8.5.3
+
diff --git a/app-arch/pigz/files/pigz-2.3-make.patch b/app-arch/pigz/files/pigz-2.3-make.patch
new file mode 100644
index 00000000000..f014c7b022f
--- /dev/null
+++ b/app-arch/pigz/files/pigz-2.3-make.patch
@@ -0,0 +1,25 @@
+From 545a9350f8026f6c9826dd4fa7ab6000d8826d78 Mon Sep 17 00:00:00 2001
+From: Tim Harder <radhermit@gmail.com>
+Date: Wed, 6 Mar 2013 15:51:27 -0800
+Subject: [PATCH] Respect LDFLAGS and explicitly link to math library
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 3cc231d..48d1f26 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@ CFLAGS=-O3 -Wall -Wextra
+
+
+ pigz: pigz.o yarn.o zopfli/deflate.o zopfli/blocksplitter.o zopfli/tree.o zopfli/lz77.o zopfli/cache.o zopfli/hash.o zopfli/util.o zopfli/squeeze.o zopfli/katajainen.o
+- $(CC) -o pigz $^ -lpthread -lz
++ $(CC) $(LDFLAGS) -o pigz $^ -lpthread -lz -lm
+ ln -f pigz unpigz
+
+ pigz.o: pigz.c yarn.h zopfli/deflate.h zopfli/util.h
+--
+1.8.1.5
+
diff --git a/app-arch/pigz/files/pigz-2.3.3-ldflags.patch b/app-arch/pigz/files/pigz-2.3.3-ldflags.patch
new file mode 100644
index 00000000000..51c2b81c1fc
--- /dev/null
+++ b/app-arch/pigz/files/pigz-2.3.3-ldflags.patch
@@ -0,0 +1,34 @@
+--- pigz-2.3.3/Makefile
++++ pigz-2.3.3/Makefile
+@@ -1,11 +1,11 @@
+ CC=cc
+ CFLAGS=-O3 -Wall -Wextra
+-LDFLAGS=-lz
++LIBS=-lm -lz
+ ZOPFLI=zopfli/src/zopfli/
+ # use gcc and gmake on Solaris
+
+ pigz: pigz.o yarn.o try.o ${ZOPFLI}deflate.o ${ZOPFLI}blocksplitter.o ${ZOPFLI}tree.o ${ZOPFLI}lz77.o ${ZOPFLI}cache.o ${ZOPFLI}hash.o ${ZOPFLI}util.o ${ZOPFLI}squeeze.o ${ZOPFLI}katajainen.o
+- $(CC) $(LDFLAGS) -o pigz $^ -lpthread -lm
++ $(CC) $(LDFLAGS) -o pigz $^ -lpthread $(LIBS)
+ ln -f pigz unpigz
+
+ pigz.o: pigz.c yarn.h try.h ${ZOPFLI}deflate.h ${ZOPFLI}util.h
+@@ -35,7 +35,7 @@
+ dev: pigz pigzt pigzn
+
+ pigzt: pigzt.o yarnt.o try.o ${ZOPFLI}deflate.o ${ZOPFLI}blocksplitter.o ${ZOPFLI}tree.o ${ZOPFLI}lz77.o ${ZOPFLI}cache.o ${ZOPFLI}hash.o ${ZOPFLI}util.o ${ZOPFLI}squeeze.o ${ZOPFLI}katajainen.o
+- $(CC) $(LDFLAGS) -o pigzt $^ -lpthread -lm
++ $(CC) $(LDFLAGS) -o pigzt $^ -lpthread $(LIBS)
+
+ pigzt.o: pigz.c yarn.h try.h
+ $(CC) $(CFLAGS) -DDEBUG -g -c -o pigzt.o pigz.c
+@@ -44,7 +44,7 @@
+ $(CC) $(CFLAGS) -DDEBUG -g -c -o yarnt.o yarn.c
+
+ pigzn: pigzn.o tryn.o ${ZOPFLI}deflate.o ${ZOPFLI}blocksplitter.o ${ZOPFLI}tree.o ${ZOPFLI}lz77.o ${ZOPFLI}cache.o ${ZOPFLI}hash.o ${ZOPFLI}util.o ${ZOPFLI}squeeze.o ${ZOPFLI}katajainen.o
+- $(CC) $(LDFLAGS) -o pigzn $^ -lm
++ $(CC) $(LDFLAGS) -o pigzn $^ $(LIBS)
+
+ pigzn.o: pigz.c try.h
+ $(CC) $(CFLAGS) -DDEBUG -DNOTHREAD -g -c -o pigzn.o pigz.c