summaryrefslogtreecommitdiff
path: root/app-arch/pixz
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/pixz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/pixz')
-rw-r--r--app-arch/pixz/Manifest1
-rw-r--r--app-arch/pixz/files/pixz-1.0.2-lm.patch25
-rw-r--r--app-arch/pixz/metadata.xml13
-rw-r--r--app-arch/pixz/pixz-1.0.2.ebuild47
-rw-r--r--app-arch/pixz/pixz-9999.ebuild47
5 files changed, 133 insertions, 0 deletions
diff --git a/app-arch/pixz/Manifest b/app-arch/pixz/Manifest
new file mode 100644
index 00000000000..f5ce1c9665c
--- /dev/null
+++ b/app-arch/pixz/Manifest
@@ -0,0 +1 @@
+DIST pixz-1.0.2.tgz 21425 SHA256 af9dac41edd6bf57953471f7fcbd4793810003bf911593ba4c84f7cccb5f74af SHA512 ea3f37b725a0f08e87a6bc0af19522e92bb5b34fad49cfbfcc04e7054f4537cb09c8f3b56abda7f6d27ce64535b158a676a9e69f92141190840bd9ba255961f3 WHIRLPOOL 76b8af8833b9d87718b0a1fa5f596f6aa820b176b17cbde25f7cd0cf1f6b0cdce6c4d7b7c3d82b3f7b018a60bd6ce1ae6f43263875f0eeef5c93ae889856c60e
diff --git a/app-arch/pixz/files/pixz-1.0.2-lm.patch b/app-arch/pixz/files/pixz-1.0.2-lm.patch
new file mode 100644
index 00000000000..7db039a54a9
--- /dev/null
+++ b/app-arch/pixz/files/pixz-1.0.2-lm.patch
@@ -0,0 +1,25 @@
+From 6c9d6b9020c599f850c0b719cc9c041f1667671b Mon Sep 17 00:00:00 2001
+From: Dave Vasilevsky <dave@vasilevsky.ca>
+Date: Thu, 10 Jan 2013 08:28:06 -0500
+Subject: [PATCH] Fix linking bug (issue 11)
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index fe605f2..3b27690 100644
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@ MYCFLAGS = $(patsubst %,-I%/include,$(LIBPREFIX)) $(OPT) -std=gnu99 \
+ MYLDFLAGS = $(patsubst %,-L%/lib,$(LIBPREFIX)) $(OPT) -Wall
+
+ THREADS = -lpthread
+-LIBADD = $(THREADS) -llzma -larchive
++LIBADD = $(THREADS) -lm -llzma -larchive
+
+ CC = gcc
+ COMPILE = $(CC) $(MYCFLAGS) $(CFLAGS) -c -o
+--
+1.8.1.2
+
diff --git a/app-arch/pixz/metadata.xml b/app-arch/pixz/metadata.xml
new file mode 100644
index 00000000000..3aa4e7544ed
--- /dev/null
+++ b/app-arch/pixz/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">vasi/pixz</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/pixz/pixz-1.0.2.ebuild b/app-arch/pixz/pixz-1.0.2.ebuild
new file mode 100644
index 00000000000..4d3d7d56816
--- /dev/null
+++ b/app-arch/pixz/pixz-1.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="Parallel Indexed XZ compressor"
+HOMEPAGE="https://github.com/vasi/pixz"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/vasi/pixz.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="static"
+
+LIB_DEPEND=">=app-arch/libarchive-2.8:=[static-libs(+)]
+ >=app-arch/xz-utils-5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-lm.patch
+}
+
+src_configure() {
+ use static && append-ldflags -static
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT=""
+}
+
+src_install() {
+ dobin pixz
+ doman pixz.1
+ dodoc README TODO
+}
diff --git a/app-arch/pixz/pixz-9999.ebuild b/app-arch/pixz/pixz-9999.ebuild
new file mode 100644
index 00000000000..57941097e60
--- /dev/null
+++ b/app-arch/pixz/pixz-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Parallel Indexed XZ compressor"
+HOMEPAGE="https://github.com/vasi/pixz"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="static"
+
+LIB_DEPEND=">=app-arch/libarchive-2.8:=[static-libs(+)]
+ >=app-arch/xz-utils-5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/vasi/pixz.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/vasi/${PN}/archive/v${PV}.zip -> ${P}.zip"
+ KEYWORDS="~amd64 ~arm ~x86"
+ DEPEND="${DEPEND} app-text/asciidoc"
+fi
+
+src_configure() {
+ use static && append-ldflags -static
+}
+
+src_compile() {
+ if [[ ${PV} == "9999" ]] ; then
+ emake CC="$(tc-getCC)" OPT="" all pixz.1
+ else
+ emake CC="$(tc-getCC)" OPT="" all
+ fi
+}
+
+src_install() {
+ dobin pixz
+ doman pixz.1
+ dodoc README TODO
+}