summaryrefslogtreecommitdiff
path: root/app-arch/undms
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/undms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/undms')
-rw-r--r--app-arch/undms/Manifest2
-rw-r--r--app-arch/undms/metadata.xml7
-rw-r--r--app-arch/undms/undms-1.3-r1.ebuild24
3 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/undms/Manifest b/app-arch/undms/Manifest
new file mode 100644
index 00000000000..294698d7b8c
--- /dev/null
+++ b/app-arch/undms/Manifest
@@ -0,0 +1,2 @@
+DIST undms-1.3.c.Z 13186 SHA256 d5c5396d1003f4d4125b4fe4833043e207b7315e87db3be92c2188ffbe27e8ac SHA512 9b8249bf2bc01bac755b65eb07c976c3341200469849546d8cb73c3663e475a2bd36fb12f6498d9516a5dba146a060fdf7e7f1705ff8a2d7c95f3efed013402e WHIRLPOOL 2e2687563613bdd1c0a9bfaf2bacd2afb22f2ce2cab14fb3c49d9769988bcd8ecfe5848a76a22ed440775aa67ada6e2b2d1883b0b6e8bf1a9ae7828492f4f884
+DIST undms-1.3.c.Z.readme 228 SHA256 a9e5e9ce8a0d8da3b699203b4cece10a25e159f5523086aa274f82427d9f8320 SHA512 03bed1aa29d52068d8196877374acfc715f8c729b56cfb4e8874c06509380250b70310ad50602a54cb30d8e7dbfe95e4d793626ed3950f0516d9ec42146c7fcd WHIRLPOOL dd0f8ae649a83cd338cef4b6d16957bb2a424255586711593ebacefc0fcd1cd65f27a124580e99de0a4c6f1c55175e1e38dc2d492039f2031b477686998a793e
diff --git a/app-arch/undms/metadata.xml b/app-arch/undms/metadata.xml
new file mode 100644
index 00000000000..91f4e72fb54
--- /dev/null
+++ b/app-arch/undms/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-arch/undms/undms-1.3-r1.ebuild b/app-arch/undms/undms-1.3-r1.ebuild
new file mode 100644
index 00000000000..4d27ed1f566
--- /dev/null
+++ b/app-arch/undms/undms-1.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Decompress Amiga DMS disk images to ADF"
+SRC_URI="ftp://us.aminet.net/pub/aminet/misc/unix/${P}.c.Z ftp://us.aminet.net/pub/aminet/misc/unix/${P}.c.Z.readme"
+HOMEPAGE="ftp://us.aminet.net/pub/aminet/misc/unix/"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${P}.c || die "Compilation failed"
+}
+
+src_install() {
+ dobin undms
+ newdoc "${DISTDIR}"/${P}.c.Z.readme readme
+}