summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-09-01 00:05:53 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-09-01 00:07:03 +0200
commit2d2de1c5ddcd915940686b5f0b18b0362b53b7b6 (patch)
tree60b547376558fa37e4831ff6164a5f14d0204ac5 /app-arch
parent7e65233a587d12728d90abcdce4c36a4316ca187 (diff)
downloadgentoo-2d2de1c5ddcd915940686b5f0b18b0362b53b7b6.tar.gz
gentoo-2d2de1c5ddcd915940686b5f0b18b0362b53b7b6.tar.xz
app-arch/file-roller: version bump to 3.20.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/Manifest1
-rw-r--r--app-arch/file-roller/file-roller-3.20.3.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index 3b419a170c4..f9d908b6132 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1,2 +1,3 @@
DIST file-roller-3.16.5.tar.xz 1415236 SHA256 09a68db98aa33febdad76e6977d7771b3b444da7f57ab6f4fe7d6a77e39d5a91 SHA512 83c8dddb547f36faa2728996648479255353706a266ce26e79f8f6141794d0281a9817f2a1dc687623ba8382cab93aef23675e2f3ef6d4abb9f8871f253d2c2d WHIRLPOOL 01d54e45d9d8b81c5f965622adbacac1400f56461e230999e97aa1cde135714e7e80317749c04eac7b4a49fea0fa66142b9dfbec0876b743b4709d3d17c72cce
DIST file-roller-3.20.2.tar.xz 1430448 SHA256 93188a7ac9285cb85551c327082aeaeb51ac39a9722cb96b0e29d5ec2ae353c6 SHA512 a2397215125c5bf10efcc04eb7722459acf5e11c40f3d2acb813c1c4e0de0855656c732cecb0526f850bf3e419c8407b36487c553ce9e26894fc40af309dfdf5 WHIRLPOOL e05ef7a1d86c5dceae079b8e7400acb49977903df0e90bf4bcec7774713d2afcf91311a75ba3a771fca49f6662e005ecde347328ed9e7923864a9082329a9478
+DIST file-roller-3.20.3.tar.xz 1432400 SHA256 6b5c2de4c6bd52318cacd2a398cdfa45a5f1df8a77c6652a38a6a1d3e53644e9 SHA512 afa7a7e49b357f11a8e8c2678c02f9ce1c20e3bef4c64be0930342127b11dc271369958b634985fb1305fe913182a2e5a63326afc2d1839ab116ad773ee668c3 WHIRLPOOL aa96b158971ed0105f416fc5e83d9a8810d5ececa30a5b9761b9caeeaa607e50ce635629c4aaf05fabb9391959db149cd8b4b2d69c1c765c78001e9f2a11c467
diff --git a/app-arch/file-roller/file-roller-3.20.3.ebuild b/app-arch/file-roller/file-roller-3.20.3.ebuild
new file mode 100644
index 00000000000..e90d3ac4745
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.20.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 readme.gentoo-r1
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.13.2:3
+ >=x11-libs/libnotify-0.4.3:=
+ sys-apps/file
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ nautilus? ( >=gnome-base/nautilus-3 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -f "${FILESDIR}"/3.6.0-packages.match data/packages.match || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ $(use_enable nautilus nautilus-actions) \
+ $(use_enable packagekit)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}