summaryrefslogtreecommitdiff
path: root/app-backup/duply
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/duply
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/duply')
-rw-r--r--app-backup/duply/Manifest2
-rw-r--r--app-backup/duply/duply-1.10.ebuild28
-rw-r--r--app-backup/duply/duply-1.9.2.ebuild28
-rw-r--r--app-backup/duply/files/README.gentoo4
-rw-r--r--app-backup/duply/metadata.xml18
5 files changed, 80 insertions, 0 deletions
diff --git a/app-backup/duply/Manifest b/app-backup/duply/Manifest
new file mode 100644
index 00000000000..b74a763175c
--- /dev/null
+++ b/app-backup/duply/Manifest
@@ -0,0 +1,2 @@
+DIST duply_1.10.tgz 36075 SHA256 62286bddd6efee67fb20c790e63bf25847ad65c06a4969b275e9abdb6253f6cc SHA512 10af8208d14bbb23bccc03cba5db7fbdccd8cacc0ada18cc07ad268966200884c280486ce5019385bfa8d1e61b1aecee5e38704332b45d97b47419eca995641c WHIRLPOOL dc96ba35644a88f9929ce93216b0b44901b9c7d1b5c2f58439888066ae64f7fd254e3496f12f08159ad905e4d7a06f07e09a7c9dab1318ce1e29fe101fc1c4b2
+DIST duply_1.9.2.tgz 36222 SHA256 2bfc0964ebc0bae5752e0b4a12eb8fb6f78a27739f32c9acb4ac81947506c5ab SHA512 9ef5e22f43a6854e413ed1c2b88b10d0ae75cff7b2bcd927d20a588234555e9b7eff25d094f688f9d4f8510eba6bc20f7635c0de9ab9b402966075595922333e WHIRLPOOL 6a3e79c87e0b28386f0ed6fd8eb7973659477ad278e80e292a3e6cea944fd512baffc9a455e148faeadb687a46a8e274ce86668c29f30244b5b63f1f850a9c00
diff --git a/app-backup/duply/duply-1.10.ebuild b/app-backup/duply/duply-1.10.ebuild
new file mode 100644
index 00000000000..c09fc50adc2
--- /dev/null
+++ b/app-backup/duply/duply-1.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="A shell frontend for duplicity"
+HOMEPAGE="http://duply.net"
+SRC_URI="mirror://sourceforge/ftplicity/${PN}_${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/txt2man"
+RDEPEND="app-backup/duplicity"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_install() {
+ dobin ${PN}
+ ./${PN} txt2man > ${PN}.1 || die
+ doman ${PN}.1
+ readme.gentoo_create_doc
+}
diff --git a/app-backup/duply/duply-1.9.2.ebuild b/app-backup/duply/duply-1.9.2.ebuild
new file mode 100644
index 00000000000..eab3a69c766
--- /dev/null
+++ b/app-backup/duply/duply-1.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="A shell frontend for duplicity"
+HOMEPAGE="http://duply.net"
+SRC_URI="mirror://sourceforge/ftplicity/${PN}_${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-text/txt2man"
+RDEPEND="app-backup/duplicity"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_install() {
+ dobin ${PN}
+ ./${PN} txt2man > ${PN}.1 || die
+ doman ${PN}.1
+ readme.gentoo_create_doc
+}
diff --git a/app-backup/duply/files/README.gentoo b/app-backup/duply/files/README.gentoo
new file mode 100644
index 00000000000..99d9a132047
--- /dev/null
+++ b/app-backup/duply/files/README.gentoo
@@ -0,0 +1,4 @@
+If you use duply at the first time please have a
+look at the the usage help text "duply usage"
+for further information."
+
diff --git a/app-backup/duply/metadata.xml b/app-backup/duply/metadata.xml
new file mode 100644
index 00000000000..3d57caf5180
--- /dev/null
+++ b/app-backup/duply/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>gentoo@pennewiss.de</email>
+ <name>Marcel Pennewiß</name>
+ <description>Proxy-maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ftplicity</remote-id>
+ </upstream>
+</pkgmetadata>