summaryrefslogtreecommitdiff
path: root/app-backup/qt4-fsarchiver
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/qt4-fsarchiver
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/qt4-fsarchiver')
-rw-r--r--app-backup/qt4-fsarchiver/Manifest2
-rw-r--r--app-backup/qt4-fsarchiver/metadata.xml10
-rw-r--r--app-backup/qt4-fsarchiver/qt4-fsarchiver-0.6.19.6.ebuild66
-rw-r--r--app-backup/qt4-fsarchiver/qt4-fsarchiver-0.6.19.7.ebuild66
4 files changed, 144 insertions, 0 deletions
diff --git a/app-backup/qt4-fsarchiver/Manifest b/app-backup/qt4-fsarchiver/Manifest
new file mode 100644
index 00000000000..b1bc75fd5db
--- /dev/null
+++ b/app-backup/qt4-fsarchiver/Manifest
@@ -0,0 +1,2 @@
+DIST qt4-fsarchiver-0.6.19-6.tar.gz 480288 SHA256 fbc3861ba45050840e0224b4dc39da164353ea8b35e7be6ea2f05e8ad90b925b SHA512 b542cec478f901cf1c6678a202183e9c7f047efd906a53bd2882385482d0bf20fbd46374fc60751e7e5ee04a6048643e3fb58ffefd883799c54b48c307aad1f3 WHIRLPOOL e6a50b016fe8bb15d0f5ee5c634b009b859d183ea05bdcf1b17d6690047ef96258bec7acc71dff5f51f3d61c9aaad48ae25316601d2baeccae4cb05dba38ea0e
+DIST qt4-fsarchiver-0.6.19-7.tar.gz 481129 SHA256 b4de5c34a0acad5104ec55dbef02b1a0f5c54d4dfddf9bd04073fe684846cd7c SHA512 31495858a27f7a1790ed492d69ff70eaae458f48f2afbe066507913289c3ed861389a201f03a56e3a5a3665eddae58371fe1d648bd10a3e96fb8240a40965b1c WHIRLPOOL d1cc9fc95f5fe59c727b38b5ad5571da06d49ada5f38fdbb27a8d252e03d23a8cbec40e94b6c73896c2f030ed67ab65da753fe7ba07dbb87cf2d2c0d90f9901d
diff --git a/app-backup/qt4-fsarchiver/metadata.xml b/app-backup/qt4-fsarchiver/metadata.xml
new file mode 100644
index 00000000000..bd20383e89d
--- /dev/null
+++ b/app-backup/qt4-fsarchiver/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">qt4-fsarchiver</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-backup/qt4-fsarchiver/qt4-fsarchiver-0.6.19.6.ebuild b/app-backup/qt4-fsarchiver/qt4-fsarchiver-0.6.19.6.ebuild
new file mode 100644
index 00000000000..5276dde6ffc
--- /dev/null
+++ b/app-backup/qt4-fsarchiver/qt4-fsarchiver-0.6.19.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils versionator
+
+MY_P="${PN}-$(replace_version_separator 3 '-')"
+MIN_PV="$(get_version_component_range 1-3)"
+
+DESCRIPTION="Qt4 frontend for fsarchiver"
+HOMEPAGE="http://qt4-fsarchiver.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+
+CDEPEND="app-arch/bzip2
+ app-arch/xz-utils
+ dev-libs/libgcrypt:=
+ dev-libs/lzo
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-libs/zlib"
+RDEPEND="${CDEPEND}
+ >=app-backup/fsarchiver-${MIN_PV}[lzma,lzo]"
+DEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # fix .desktop file
+ sed -i \
+ -e '/Encoding/d' starter/"${PN}".desktop \
+ || die "sed on qt4-fsarchiver.desktop failed"
+ # fix icon installation location
+ sed -i \
+ -e "/icon.path/s:app-install/icons:${PN}:" "${PN}.pro" \
+ || die "sed on ${PN}.pro failed"
+}
+
+src_compile() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "optional dependencies:"
+ elog " sys-fs/btrfs-progs"
+ elog " sys-fs/jfsutils"
+ elog " sys-fs/ntfs3g[ntfsprogs]"
+ elog " sys-fs/reiser4progs"
+ elog " sys-fs/reiserfsprogs"
+ elog " sys-fs/sshfs-fuse"
+ elog " sys-fs/xfsprogs"
+}
diff --git a/app-backup/qt4-fsarchiver/qt4-fsarchiver-0.6.19.7.ebuild b/app-backup/qt4-fsarchiver/qt4-fsarchiver-0.6.19.7.ebuild
new file mode 100644
index 00000000000..1bcf6b5b11f
--- /dev/null
+++ b/app-backup/qt4-fsarchiver/qt4-fsarchiver-0.6.19.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils versionator
+
+MY_P="${PN}-$(replace_version_separator 3 '-')"
+MIN_PV="$(get_version_component_range 1-3)"
+
+DESCRIPTION="Qt4 frontend for fsarchiver"
+HOMEPAGE="http://qt4-fsarchiver.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CDEPEND="app-arch/bzip2
+ app-arch/xz-utils
+ dev-libs/libgcrypt:=
+ dev-libs/lzo
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-libs/zlib"
+RDEPEND="${CDEPEND}
+ >=app-backup/fsarchiver-${MIN_PV}[lzma,lzo]"
+DEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # fix .desktop file
+ sed -i \
+ -e '/Encoding/d' starter/"${PN}".desktop \
+ || die "sed on qt4-fsarchiver.desktop failed"
+ # fix icon installation location
+ sed -i \
+ -e "/icon.path/s:app-install/icons:${PN}:" "${PN}.pro" \
+ || die "sed on ${PN}.pro failed"
+}
+
+src_compile() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "optional dependencies:"
+ elog " sys-fs/btrfs-progs"
+ elog " sys-fs/jfsutils"
+ elog " sys-fs/ntfs3g[ntfsprogs]"
+ elog " sys-fs/reiser4progs"
+ elog " sys-fs/reiserfsprogs"
+ elog " sys-fs/sshfs-fuse"
+ elog " sys-fs/xfsprogs"
+}