summaryrefslogtreecommitdiff
path: root/app-backup
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2015-12-28 17:53:11 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2015-12-28 17:53:35 +0100
commitbb463dca0ce2db0e942f5c485dbae4c0ee9de643 (patch)
treefd621681a45ffff1a2e3fa802e6ce306e7dc90c3 /app-backup
parenta074ec2f6e647417f66450299cd89fbce2f6aca6 (diff)
downloadgentoo-bb463dca0ce2db0e942f5c485dbae4c0ee9de643.tar.gz
gentoo-bb463dca0ce2db0e942f5c485dbae4c0ee9de643.tar.xz
app-backup/obnam: added patch to make sftp plugin work with paramiko
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/obnam/files/obnam-1.18.2-obnamlib-sftp-Add-prefetch-size-argument.patch31
-rw-r--r--app-backup/obnam/obnam-1.18.2-r1.ebuild (renamed from app-backup/obnam/obnam-1.18.2.ebuild)6
2 files changed, 36 insertions, 1 deletions
diff --git a/app-backup/obnam/files/obnam-1.18.2-obnamlib-sftp-Add-prefetch-size-argument.patch b/app-backup/obnam/files/obnam-1.18.2-obnamlib-sftp-Add-prefetch-size-argument.patch
new file mode 100644
index 00000000000..20a8e7cb6b7
--- /dev/null
+++ b/app-backup/obnam/files/obnam-1.18.2-obnamlib-sftp-Add-prefetch-size-argument.patch
@@ -0,0 +1,31 @@
+From 738e9291ed15980bdac568fc5f9507a43897ba52 Mon Sep 17 00:00:00 2001
+From: Kyle Manna <kyle@kylemanna.com>
+Date: Fri, 6 Nov 2015 08:12:50 -0800
+Subject: [PATCH] obnamlib: sftp: Add prefetch size argument
+
+Paramiko made this argument required in v1.16. Details at
+https://github.com/paramiko/paramiko/commit/49072f3537a8981e9d448c22481a1d2b92c03643
+
+Attempt to fetch the entire file. I'm unsure if this is the original
+intent. If the entire file isn't to be fetched, then the prefetch() is
+probably not needed.
+---
+ obnamlib/plugins/sftp_plugin.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/obnamlib/plugins/sftp_plugin.py b/obnamlib/plugins/sftp_plugin.py
+index c4d5c2f..a5bc72b 100644
+--- a/obnamlib/plugins/sftp_plugin.py
++++ b/obnamlib/plugins/sftp_plugin.py
+@@ -555,7 +555,7 @@ class SftpFS(obnamlib.VirtualFileSystem):
+ def cat(self, pathname):
+ self._delay()
+ f = self.open(pathname, 'rb')
+- f.prefetch()
++ f.prefetch(self.lstat(pathname).st_size)
+ chunks = []
+ while True:
+ chunk = f.read(self.chunk_size)
+--
+2.6.2
+
diff --git a/app-backup/obnam/obnam-1.18.2.ebuild b/app-backup/obnam/obnam-1.18.2-r1.ebuild
index 8b909251b95..dff2085b7a6 100644
--- a/app-backup/obnam/obnam-1.18.2.ebuild
+++ b/app-backup/obnam/obnam-1.18.2-r1.ebuild
@@ -22,13 +22,17 @@ DEPEND="${PYTHON_DEPS}
dev-python/cliapp[${PYTHON_USEDEP}]
dev-python/fuse-python[${PYTHON_USEDEP}]
dev-python/larch[${PYTHON_USEDEP}]
- >dev-python/paramiko-1.13.0[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/tracing[${PYTHON_USEDEP}]
dev-python/ttystatus[${PYTHON_USEDEP}]
"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-obnamlib-sftp-Add-prefetch-size-argument.patch"
+}
+
src_compile() {
addwrite /proc/self/comm
distutils-r1_src_compile