summaryrefslogtreecommitdiff
path: root/app-benchmarks/pipebench/files
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-28 14:10:05 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-28 16:06:13 +0100
commitdb695fb165071cb86660dda3f99bc1930d54150d (patch)
tree0b1e4c488b6373a9145d08aa60d87328686599f7 /app-benchmarks/pipebench/files
parent703a2af54d866fd23cafff62f954ed8b84bab0a6 (diff)
downloadgentoo-db695fb165071cb86660dda3f99bc1930d54150d.tar.gz
gentoo-db695fb165071cb86660dda3f99bc1930d54150d.tar.xz
app-benchmarks/pipebench: [QA] Respect LDFLAGS
Closes: https://bugs.gentoo.org/334909 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-benchmarks/pipebench/files')
-rw-r--r--app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch
new file mode 100644
index 00000000000..2d79d80ef7b
--- /dev/null
+++ b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,16 +1,11 @@
+ # $Id: Makefile,v 1.2 2002/12/15 19:58:36 marvin Exp $
+
+-CC=gcc
+-CFLAGS=-Wall -w -pedantic
+
+ all: pipebench
+ doc: pipebench.1
+ install: pipebench
+- cp pipebench /usr/local/bin/
+- cp pipebench.1 /usr/local/man/man1/
+-
+-pipebench: pipebench.c
+- $(CC) $(CFLAGS) -o pipebench pipebench.c
++ mkdir -p $(DESTDIR)$(EPREFIX)/usr/bin && cp pipebench $(DESTDIR)$(EPREFIX)/usr/bin/
++ mkdir -p $(DESTDIR)$(EPREFIX)/usr/share/man/man1 && cp pipebench.1 $(DESTDIR)$(EPREFIX)/usr/share/man/man1/
+
+ pipebench.1: pipebench.yodl
+ yodl2man -o pipebench.1 pipebench.yodl