summaryrefslogtreecommitdiff
path: root/app-cdr/isomaster/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/isomaster/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/isomaster/files')
-rw-r--r--app-cdr/isomaster/files/isomaster-1.3.11-make-install.patch34
-rw-r--r--app-cdr/isomaster/files/isomaster-1.3.5-ldflags.diff11
-rw-r--r--app-cdr/isomaster/files/isomaster-1.3.9-asneeded.patch14
-rw-r--r--app-cdr/isomaster/files/isomaster-1.3.9-iniparser-3.0.0.patch24
4 files changed, 83 insertions, 0 deletions
diff --git a/app-cdr/isomaster/files/isomaster-1.3.11-make-install.patch b/app-cdr/isomaster/files/isomaster-1.3.11-make-install.patch
new file mode 100644
index 00000000000..90ebe346a0c
--- /dev/null
+++ b/app-cdr/isomaster/files/isomaster-1.3.11-make-install.patch
@@ -0,0 +1,34 @@
+From 5717fb2da383d0c8c80fffdbe3ced568b2151f86 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Thu, 29 May 2014 18:58:48 +0200
+Subject: [PATCH] Fix "make install"
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+[..]
+for FILE in bkisofs-manual/manual/*html; do \
+ install -m 644 $FILE DESTDIR/usr/share/doc/isomaster-1.3.11/bkisofs; \
+ done;
+install: cannot create regular file ‘DESTDIR/usr/share/doc/isomaster-1.3.11/bkisofs’: No such file or directory
+[..]
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 116b2fd..fa4989e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -129,7 +129,7 @@ endif
+ $(INSTALL) -m 644 isomaster.1 $(DESTDIR)$(MYMANPATH)
+ $(INSTALL) -d $(DESTDIR)$(DESKTOPPATH)
+ $(INSTALL) -m 644 isomaster.desktop $(DESTDIR)$(DESKTOPPATH)
+- #$(INSTALL) -d $(DESTDIR)$(MYDOCPATH)
++ $(INSTALL) -d $(DESTDIR)$(MYDOCPATH)
+ for FILE in bkisofs-manual/manual/*html; do \
+ $(INSTALL) -m 644 $$FILE $(DESTDIR)$(MYDOCPATH); \
+ done;
+--
+1.9.3
+
diff --git a/app-cdr/isomaster/files/isomaster-1.3.5-ldflags.diff b/app-cdr/isomaster/files/isomaster-1.3.5-ldflags.diff
new file mode 100644
index 00000000000..8f328912552
--- /dev/null
+++ b/app-cdr/isomaster/files/isomaster-1.3.5-ldflags.diff
@@ -0,0 +1,11 @@
+--- Makefile
++++ Makefile
+@@ -64,7 +64,7 @@
+
+ isomaster: $(OBJECTS) lib iniparser
+ @echo 'Linking isomaster'
+- @$(CC) $(OBJECTS) bk/bk.a iniparser-2.17/libiniparser.a $(CFLAGS) $(CPPFLAGS) `pkg-config --libs gtk+-2.0` -o isomaster
++ @$(CC) $(OBJECTS) bk/bk.a iniparser-2.17/libiniparser.a $(LDFLAGS) $(CFLAGS) $(CPPFLAGS) `pkg-config --libs gtk+-2.0` -o isomaster
+
+ # static pattern rule
+ $(OBJECTS): %.o: %.c %.h bk/bk.h Makefile
diff --git a/app-cdr/isomaster/files/isomaster-1.3.9-asneeded.patch b/app-cdr/isomaster/files/isomaster-1.3.9-asneeded.patch
new file mode 100644
index 00000000000..102f54db4a1
--- /dev/null
+++ b/app-cdr/isomaster/files/isomaster-1.3.9-asneeded.patch
@@ -0,0 +1,14 @@
+--- Makefile
++++ Makefile
+@@ -75,9 +75,9 @@
+ isomaster: $(OBJECTS) lib iniparser
+ @echo 'Linking isomaster'
+ ifndef USE_SYSTEM_INIPARSER
+- @$(CC) $(LDFLAGS) `pkg-config --libs gtk+-2.0` $(OBJECTS) bk/bk.a iniparser-2.17/libiniparser.a -o isomaster
++ @$(CC) $(LDFLAGS) $(OBJECTS) -o isomaster bk/bk.a iniparser-2.17/libiniparser.a `pkg-config --libs gtk+-2.0`
+ else
+- @$(CC) $(LDFLAGS) `pkg-config --libs gtk+-2.0` $(OBJECTS) bk/bk.a -liniparser -o isomaster
++ @$(CC) $(LDFLAGS) $(OBJECTS) -o isomaster bk/bk.a -liniparser `pkg-config --libs gtk+-2.0`
+ endif
+
+ # static pattern rule
diff --git a/app-cdr/isomaster/files/isomaster-1.3.9-iniparser-3.0.0.patch b/app-cdr/isomaster/files/isomaster-1.3.9-iniparser-3.0.0.patch
new file mode 100644
index 00000000000..902028a660a
--- /dev/null
+++ b/app-cdr/isomaster/files/isomaster-1.3.9-iniparser-3.0.0.patch
@@ -0,0 +1,24 @@
+From d2cea534819267e9e8b7348b7cf6fdbad72c7b11 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 21 Jan 2012 21:34:33 +0100
+Subject: [PATCH] Fix compilation against iniparser 3.0.0 (bug #399629)
+
+---
+ Makefile | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 3f4b383..43187fc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -66,6 +66,7 @@ CPPFLAGS += -D_FILE_OFFSET_BITS=64
+
+ ifdef USE_SYSTEM_INIPARSER
+ CPPFLAGS += -DUSE_SYSTEM_INIPARSER=$(USE_SYSTEM_INIPARSER)
++CPPFLAGS += -Diniparser_setstr=iniparser_set # Define went away with iniparser 3.0.0, Gentoo bug #399629
+ endif
+
+ OBJECTS = isomaster.o window.o browser.o fsbrowser.o isobrowser.o error.o about.o settings.o boot.o editfile.o
+--
+1.7.8.4
+