summaryrefslogtreecommitdiff
path: root/app-cdr/xcdroast
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/xcdroast
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/xcdroast')
-rw-r--r--app-cdr/xcdroast/Manifest1
-rw-r--r--app-cdr/xcdroast/files/cdda2wav_version.patch54
-rw-r--r--app-cdr/xcdroast/files/fix_cddb_hidden_tracks.patch45
-rw-r--r--app-cdr/xcdroast/files/io_compile.patch21
-rw-r--r--app-cdr/xcdroast/metadata.xml9
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha16-r1.ebuild74
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha16.ebuild66
7 files changed, 270 insertions, 0 deletions
diff --git a/app-cdr/xcdroast/Manifest b/app-cdr/xcdroast/Manifest
new file mode 100644
index 00000000000..a3a0f00c6f5
--- /dev/null
+++ b/app-cdr/xcdroast/Manifest
@@ -0,0 +1 @@
+DIST xcdroast-0.98alpha16.tar.gz 3563666 SHA256 a2b96bb9799b5880befe2d01c5e6a0b63110dd61f59384935b750e72bc73984d SHA512 dec789955eb70a14f6bcb7c0895a6ca4b7c471cc5ee7ab12af1e671c8586c481c4a05e20eb42724d686d561a551809d9437dafadd3cd081079cefc28e0b94df7 WHIRLPOOL 06536da5dd32001ac71d9e6c9ef66869f2a14660b272cf9e711556a74d6e1bbbcb9eb6508a51a74e2f366933e5f43ca6fc5cea582fe0e96e459a66a9ec3c199d
diff --git a/app-cdr/xcdroast/files/cdda2wav_version.patch b/app-cdr/xcdroast/files/cdda2wav_version.patch
new file mode 100644
index 00000000000..cd001e0ee7b
--- /dev/null
+++ b/app-cdr/xcdroast/files/cdda2wav_version.patch
@@ -0,0 +1,54 @@
+diff -urNad xcdroast-0.98+0alpha16~/src/io.c xcdroast-0.98+0alpha16/src/io.c
+--- xcdroast-0.98+0alpha16~/src/io.c 2008-08-21 15:11:40.000000000 +0200
++++ xcdroast-0.98+0alpha16/src/io.c 2009-12-29 22:54:08.571188849 +0100
+@@ -10062,6 +10062,7 @@
+
+ gint check_version_cdda2wav(gchar *match, gchar *found) {
+ gchar line[MAXLINE];
++gchar vline[MAXLINE];
+ gchar ver[MAXLINE];
+ FILE *fpin;
+ gchar *p;
+@@ -10076,32 +10077,38 @@
+ }
+
+ strcpy(line,"");
++ strcpy(vline,"");
+ for (;;) {
+ if (fgets(line,MAXLINE,fpin) == NULL)
+ break;
+ dodebug(10,"got: %s",line);
++
++ /* only get first line */
++ if (strcmp(vline,"") == 0) {
++ strncpy(vline, line, MAXLINE);
++ }
+ }
+
+ if (pclose(fpin) == -1) {
+ g_error("pclose error\n");
+ }
+
+- if (strcmp(line,"") == 0 || strstr(line,"sh:") != NULL) {
++ if (strcmp(vline,"") == 0 || strstr(vline,"sh:") != NULL) {
+ /* failed to open - permission denied */
+ return 2;
+ }
+
+- /* now line contains the version string of cdda2wav */
++ /* now vline contains the version string of cdda2wav */
+ /* try to extract the version number */
+
+- p = strstr(line,"version");
++ p = strstr(vline,"version");
+ if (p != NULL) {
+ p = strtok(p+8, " _");
+ if (p != NULL) {
+ strcpy(ver,p);
+ }
+ } else {
+- p = strstr(line,"cdda2wav");
++ p = strstr(vline,"cdda2wav");
+ if (p != NULL) {
+ p = strtok(p+9, " ");
+ if (p != NULL) {
diff --git a/app-cdr/xcdroast/files/fix_cddb_hidden_tracks.patch b/app-cdr/xcdroast/files/fix_cddb_hidden_tracks.patch
new file mode 100644
index 00000000000..d2e15ef54c6
--- /dev/null
+++ b/app-cdr/xcdroast/files/fix_cddb_hidden_tracks.patch
@@ -0,0 +1,45 @@
+--- src/io.c
++++ src/io.c
+@@ -2665,6 +2665,8 @@
+ g_error("Unexpected output in cdda2wav toc-output\n");
+ }
+ trackinfo[tocnr]->track_nr = atoi(p1);
++ if (trackinfo[tocnr]->track_nr == 0)
++ cdinfo.nr_tracks++;
+ trackinfo[tocnr]->isosize = -1;
+
+ /* reststring into tmp2 - strip to remove leading spaces */
+@@ -8401,6 +8403,9 @@
+ if (extract_quoted(tmp) != 0)
+ return;
+
++ if (matchnr == 0 && trackinfo[matchnr]->track_nr == 0)
++ matchnr++;
++
+ if (mode == 0) {
+ if (matchnr >= cdinfo.nr_tracks) {
+ g_warning("invalid track count from cddb-server\n");
+@@ -8482,14 +8487,20 @@
+
+ /* build of command line */
+ if (mode == 0 || mode == 2) {
++ gint ntr = cdinfo.nr_tracks;
++
++ if (ntr > 0 && trackinfo[0]->track_nr == 0)
++ ntr--;
+ g_snprintf(tmp,MAXLINE,"cddb query %s %d ",
+- cdinfo.cddb_discid, cdinfo.nr_tracks);
++ cdinfo.cddb_discid, ntr);
+ for (i = 0; i < cdinfo.nr_tracks; i++) {
++ if (trackinfo[i]->track_nr == 0)
++ continue;
+ g_snprintf(tmp2,MAXLINE,"%d ",
+ trackinfo[i]->start_sec + 150);
+ strcat(tmp,tmp2);
+ }
+- g_snprintf(tmp2,MAXLINE,"%d",cdinfo.total_size / 75);
++ g_snprintf(tmp2,MAXLINE,"%d",(cdinfo.leadout + 150) / 75);
+ strcat(tmp,tmp2);
+ } else {
+ /* get data from toc file */
+
diff --git a/app-cdr/xcdroast/files/io_compile.patch b/app-cdr/xcdroast/files/io_compile.patch
new file mode 100644
index 00000000000..7285bd335df
--- /dev/null
+++ b/app-cdr/xcdroast/files/io_compile.patch
@@ -0,0 +1,21 @@
+--- src/io.c.org 2009-02-24 09:38:27.000000000 +0100
++++ src/io.c 2009-02-24 09:45:18.000000000 +0100
+@@ -1903,7 +1903,8 @@
+ }
+
+ strcpy(str,"");
+- fgets(str,MAXLINE,fpin);
++ if (fgets(str,MAXLINE,fpin) == NULL)
++ g_error("fgets error\n");
+
+ if (pclose(fpin) == -1) {
+ g_error("pclose error\n");
+@@ -4720,7 +4721,7 @@
+ dolog(3, "Saving extended output to %s\n", fname);
+
+ /* write to file */
+- fd = open(fname,O_WRONLY | O_CREAT);
++ fd = open(fname, O_WRONLY | O_CREAT, S_IRUSR | S_IWUSR);
+ if (fd < 0) {
+ g_warning("Can't open file %s for writing\n",fname);
+ return 1;
diff --git a/app-cdr/xcdroast/metadata.xml b/app-cdr/xcdroast/metadata.xml
new file mode 100644
index 00000000000..a180a61abbc
--- /dev/null
+++ b/app-cdr/xcdroast/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-optical</herd>
+ <longdescription>Menu based front-end to mkisofs and cdrecord</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xcdroast</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha16-r1.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha16-r1.ebuild
new file mode 100644
index 00000000000..6792f533782
--- /dev/null
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha16-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit gnome2-utils eutils
+
+DESCRIPTION="Lightweight cdrtools front-end for CD and DVD writing"
+HOMEPAGE="http://www.xcdroast.org/"
+SRC_URI="mirror://sourceforge/xcdroast/${P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2:2
+ app-cdr/cdrtools"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/cdda2wav_version.patch \
+ "${FILESDIR}"/fix_cddb_hidden_tracks.patch \
+ "${FILESDIR}"/io_compile.patch
+
+ # fix Norwegian locales
+ mv po/{no,nb}.po || die
+ mv po/{no,nb}.gmo || die
+ sed -i -e 's/no/nb/' po/LINGUAS || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-gtk2 \
+ --disable-dependency-tracking \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc
+}
+
+src_compile() {
+ emake PREFIX=/usr || die
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README doc/{README*,DOCUMENTATION,FAQ,TRANS*} \
+ doc/manual/README.txt
+
+ insinto /usr/share/doc/${PF}/manual
+ doins doc/manual/xcdroast-manual.pdf
+
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins xpms/xcdricon.xpm xcdroast.xpm
+
+ make_desktop_entry xcdroast "X-CD-Roast" xcdroast "AudioVideo;DiscBurning"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha16.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha16.ebuild
new file mode 100644
index 00000000000..84391499a79
--- /dev/null
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha16.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit gnome2-utils eutils
+
+DESCRIPTION="Lightweight cdrtools front-end for CD and DVD writing"
+HOMEPAGE="http://www.xcdroast.org/"
+SRC_URI="mirror://sourceforge/xcdroast/${P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2:2
+ app-cdr/cdrtools"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/io_compile.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-gtk2 \
+ --disable-dependency-tracking \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc
+}
+
+src_compile() {
+ emake PREFIX=/usr || die
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README doc/{README*,DOCUMENTATION,FAQ,TRANS*} \
+ doc/manual/README.txt
+
+ insinto /usr/share/doc/${PF}/manual
+ doins doc/manual/xcdroast-manual.pdf
+
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins xpms/xcdricon.xpm xcdroast.xpm
+
+ make_desktop_entry xcdroast "X-CD-Roast" xcdroast "AudioVideo;DiscBurning"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}