summaryrefslogtreecommitdiff
path: root/app-crypt/acme
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-03 20:56:28 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-03 20:56:28 +0100
commit1d6a2cb83d2c4d929a671db17c9ce69cf9f5c372 (patch)
tree2d716a08f7c46795076473ddba088b9c6898a5c6 /app-crypt/acme
parent31300022491089d38d839a6bb411c0f78a33ddf6 (diff)
downloadgentoo-1d6a2cb83d2c4d929a671db17c9ce69cf9f5c372.tar.gz
gentoo-1d6a2cb83d2c4d929a671db17c9ce69cf9f5c372.tar.xz
Revert "app-crypt/{acme,letsencrypt}: add ebuilds for latest snapshot"
This reverts commit c37dff06cc5632de78ff283857f211c0361d5582. Breaks acme live ebuild. Repoman complains about description. Huge changes to the ebuild without any communication.
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-0.0.0_pre20151123.ebuild50
-rw-r--r--app-crypt/acme/acme-9999.ebuild29
3 files changed, 8 insertions, 72 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
deleted file mode 100644
index 78c4d5188e3..00000000000
--- a/app-crypt/acme/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST letsencrypt-0.0.0.dev20151123.tar.gz 403690 SHA256 3f909ef521ab91eade4fa83f1f72c4b1cb74c9192144bc072d999248eb25e902 SHA512 e62cd4bf966b75e159949d84eda1005649dd4f11efbb1515601a5c6690e09ea1cc73bb3f535b6b20655752b7218fa3f02cf50e4cb12a335d76b10461e385aa96 WHIRLPOOL 5352083e3eabe69ea07b830fcdd3d9de2f431d5b8681c3484288feb2f6394d1c4dd9d46feffe08f7733015755e39df24e61293915877b97470339a3fa11c668c
diff --git a/app-crypt/acme/acme-0.0.0_pre20151123.ebuild b/app-crypt/acme/acme-0.0.0_pre20151123.ebuild
deleted file mode 100644
index cdd87cd8e6f..00000000000
--- a/app-crypt/acme/acme-0.0.0_pre20151123.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-MY_PN="letsencrypt"
-MY_PV="${PV/_pre/.dev}"
-MY_P="${MY_PN}-${MY_PV}"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
- inherit git-r3 distutils-r1
-else
- SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="An implementation of the ACME protocol"
-HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/ndg-httpsclient-0.4[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
- dev-python/pyrfc3339[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}/${PN}"
-
-python_test() {
- nosetests -w ${PN} || die
-}
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 050f571d38f..1f936403434 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -3,28 +3,18 @@
# $Id$
EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
-inherit distutils-r1
+inherit git-r3 distutils-r1
-MY_PN="letsencrypt"
-MY_PV="${PV/_pre/.dev}"
-MY_P="${MY_PN}-${MY_PV}"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
- inherit git-r3 distutils-r1
-else
- SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="An implementation of the Automatic Certificate Management Environment (ACME) protocol"
+DESCRIPTION="An implementation of the ACME protocol"
HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
+KEYWORDS=""
IUSE="test"
RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
@@ -37,13 +27,10 @@ RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )"
+DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
-S="${WORKDIR}/${MY_P}/${PN}"
+S=${WORKDIR}/${P}/${PN}
python_test() {
nosetests -w ${PN} || die