summaryrefslogtreecommitdiff
path: root/app-crypt/acr38u/acr38u-1.7.11-r1.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/acr38u/acr38u-1.7.11-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/acr38u/acr38u-1.7.11-r1.ebuild')
-rw-r--r--app-crypt/acr38u/acr38u-1.7.11-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/acr38u/acr38u-1.7.11-r1.ebuild b/app-crypt/acr38u/acr38u-1.7.11-r1.ebuild
new file mode 100644
index 00000000000..2dcc78feab1
--- /dev/null
+++ b/app-crypt/acr38u/acr38u-1.7.11-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib eutils versionator autotools toolchain-funcs udev
+
+MY_P=ACR38_LINUX_$(get_version_component_range 1)00$(get_version_component_range 2)$(get_version_component_range 3)_P
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="Non CCID driver for ACR38 AC1038-based Smart Card Reader"
+
+#SRC_URI="http://www.acs.com.hk/drivers/eng/${MY_P}.tar.bz2"
+# tarball release is encapsuled in a .zip file :-(
+# http://www.acs.com.hk/drivers/eng/ACR38_Driver_Lnx_101_P.zip
+# I'm waiting an answer from info@acs.com.hk about that !
+SRC_URI="http://www.linuxunderground.be/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.acs.com.hk"
+
+# Make this safe from collisions, require a version of pcsc-lite that
+# uses libusb-1.0 and use the wrapper library instead.
+# Changed back from dev-libs/libusb-compat to virtual/libusb:0 because
+# libusb-compat is marked stable and primary in the virtual. -ssuominen
+RDEPEND=">=sys-apps/pcsc-lite-1.6.4
+ virtual/libusb:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+IUSE=""
+
+src_prepare() {
+ epatch_user
+
+ sed -i -e '/pcdir/s:@prefix@/lib:$(libdir):' src/controllib/Makefile.am
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-static=false \
+ --enable-usbdropdir="${D}/usr/$(get_libdir)/readers/usb"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ prune_libtool_files
+
+ # note: for eudev support this pkg may always need to install rules to /usr
+ udev_newrules "${FILESDIR}"/${PV}.rules 92-pcscd-acr38u.rules
+}