summaryrefslogtreecommitdiff
path: root/app-crypt/cardpeek
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/cardpeek
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/cardpeek')
-rw-r--r--app-crypt/cardpeek/Manifest3
-rw-r--r--app-crypt/cardpeek/cardpeek-0.7.1.ebuild24
-rw-r--r--app-crypt/cardpeek/cardpeek-0.7.2.ebuild24
-rw-r--r--app-crypt/cardpeek/cardpeek-0.8.2.ebuild25
-rw-r--r--app-crypt/cardpeek/metadata.xml5
5 files changed, 81 insertions, 0 deletions
diff --git a/app-crypt/cardpeek/Manifest b/app-crypt/cardpeek/Manifest
new file mode 100644
index 00000000000..7e2efedb9c2
--- /dev/null
+++ b/app-crypt/cardpeek/Manifest
@@ -0,0 +1,3 @@
+DIST cardpeek-0.7.1.tar.gz 599238 SHA256 fa7f4fcabf211fefb968a5a49099e9a07430995556b7d59e95eeefef59538546 SHA512 8ea7f69e096de37543fec779372355a6f6cad709e43a4a66a072b453f962ebe55d25e432fb426cd88824f7165d724ddc6da55a6106e571608162b8094823be45 WHIRLPOOL 95f41d53840969beb3b98729c22ed8fe1e781ab6fe36ad3387cddf52963c2d56f5bca95955681cea839ce64ab6afddfc4d3cbf403e320d8dfec37ac0bd3a68bd
+DIST cardpeek-0.7.2.tar.gz 1130295 SHA256 9908b38a91b4df80ec5a6d6a89780dd41684dc1f203587c1bcc8e4a13cb24ed2 SHA512 9fd1790794b8d092859670bb36a0cdd235e7d098d563032ccdb8143eac00bb77532f1ab918897c4b753afd184079975de34a6f645e31eadb28b6c5a81d344ecd WHIRLPOOL 777397ca535d820453e4d315be495fc5cf845feea457c666cf935d19b8e2c7556b51e4e23f8d009c6165626c450fe5b92413841d0ee56fd6f1d549716ee05e56
+DIST cardpeek-0.8.2.tar.gz 1361187 SHA256 5c616aca68918ce35c8c8378006afdb524f9eef76a2ccc296f5365d389b46c61 SHA512 184539ef926a6ac63d41926b05160d6b91c0ca041d1b40a3e2f5314f9cb35730fbcb9be7c08d2be6f94bc121021168c45235bfa4ccac0fbd28c47159c7a89602 WHIRLPOOL 88e81a52fa485cd56a6e40f99cd5bcfb0532bb86b4c6ac4a789d0118de1468004ddb8963f778eaf5329a5bccf663a2040dc3c2a32d2c0f9124778239212e783d
diff --git a/app-crypt/cardpeek/cardpeek-0.7.1.ebuild b/app-crypt/cardpeek/cardpeek-0.7.1.ebuild
new file mode 100644
index 00000000000..59e6b7abb37
--- /dev/null
+++ b/app-crypt/cardpeek/cardpeek-0.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Tool to read the contents of smartcards"
+HOMEPAGE="https://code.google.com/p/cardpeek/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ sys-apps/pcsc-lite
+ =dev-lang/lua-5.1*
+ dev-libs/openssl"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/app-crypt/cardpeek/cardpeek-0.7.2.ebuild b/app-crypt/cardpeek/cardpeek-0.7.2.ebuild
new file mode 100644
index 00000000000..f3ee99d2107
--- /dev/null
+++ b/app-crypt/cardpeek/cardpeek-0.7.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Tool to read the contents of smartcards"
+HOMEPAGE="https://code.google.com/p/cardpeek/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ sys-apps/pcsc-lite
+ =dev-lang/lua-5.1*
+ dev-libs/openssl"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/app-crypt/cardpeek/cardpeek-0.8.2.ebuild b/app-crypt/cardpeek/cardpeek-0.8.2.ebuild
new file mode 100644
index 00000000000..8bc01faf957
--- /dev/null
+++ b/app-crypt/cardpeek/cardpeek-0.8.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Tool to read the contents of smartcards"
+HOMEPAGE="http://pannetrat.com/Cardpeek"
+SRC_URI="http://downloads.pannetrat.com/install/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="sys-apps/pcsc-lite
+ =dev-lang/lua-5.2*
+ x11-libs/gtk+:3
+ net-misc/curl
+ dev-libs/openssl"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/app-crypt/cardpeek/metadata.xml b/app-crypt/cardpeek/metadata.xml
new file mode 100644
index 00000000000..e70ecc2e1e7
--- /dev/null
+++ b/app-crypt/cardpeek/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+</pkgmetadata>