summaryrefslogtreecommitdiff
path: root/app-crypt/ccid
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2017-01-10 22:53:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2017-01-10 22:53:46 +0000
commitb9fbe704d86a06c2e1dbe67d51ed2621f0015465 (patch)
treee67af6b5bda1374b1e576e10395dd3b2d068e72c /app-crypt/ccid
parent6220d08b6779cb91e44357d95b6404489a5e6ee9 (diff)
downloadgentoo-b9fbe704d86a06c2e1dbe67d51ed2621f0015465.tar.gz
gentoo-b9fbe704d86a06c2e1dbe67d51ed2621f0015465.tar.xz
Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt/ccid')
-rw-r--r--app-crypt/ccid/Manifest1
-rw-r--r--app-crypt/ccid/ccid-1.4.26.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-crypt/ccid/Manifest b/app-crypt/ccid/Manifest
index b31592462fc..bb6f1543d90 100644
--- a/app-crypt/ccid/Manifest
+++ b/app-crypt/ccid/Manifest
@@ -1,3 +1,4 @@
DIST ccid-1.4.18.tar.bz2 492113 SHA256 5fdba97a2d2eb1c652b7dd4aa0bb8cee4814bab0cf61aecb84b32b57272541aa SHA512 ff7e331431909fe9fffd4f7aae0a2395b3b755da9c898aa6a6b629f7f516c240b820669146791deb443c646dc8fc56f9100c9f987b3e7d13c24f24f81f06b1f0 WHIRLPOOL 86107ac379e5523c31aa1499e1ecd5a1f6dab5b7f748800b5a22ff2b6470e9bb590407cb8a98ad65870a832149fe8835aa42dff9a30027f0bce843640439ce1e
DIST ccid-1.4.24.tar.bz2 594507 SHA256 62cb73c6c009c9799c526f05a05e25f00f0ad86d50f82a714dedcfbf4a7e4176 SHA512 4904165fdd089cd6f28b1c27130119d3433641a9cea5d6700afd1daa2722f763e2b348a42af4a292fdd08da45c7b17b2804b32b1fbe0ff19dccf58ec3310b09f WHIRLPOOL b2f88557ae0e6fb838432eaf0d13be1f7631c7d7f4b4a0c20014b060f0368fb5acba0c15eba7fdf6d9e31dc115a9c0bec5fe1e83468943522c94b8a89e93932c
DIST ccid-1.4.25.tar.bz2 627456 SHA256 6b062b4ce0f04d6838d58e6faa255ba05222bd8ecb57a2d1116fdbe22f253609 SHA512 97ca4009e5b4522e3db913ab147bd32bd24490c798d31be6614d3b337e0ab47e93a1ae0c1dfe1cf47a41145b3b37f5a10bbbafec980c180b407b511f18f9ac2c WHIRLPOOL bad411d2a8731a8a2e8318df8f4774d1c2c124516ecbd81cd804b3bb1f504c28bd9fa74fb5c33252e9f1c2202dfe7fe952ee7eceeae1acadbae06e0e7ce84b7a
+DIST ccid-1.4.26.tar.bz2 628038 SHA256 3267bf708ab780c02f01f6241b7c7277cb892d30fd1179a9926a8cc0ca40be2f SHA512 4a2e5e9412f2aa4870e14114e54da96fd8b3418ea6d3a236b83e19d6349adb20a94ef7f48628c108f8459f008c10b0606bbf4d797ae4be9183e1acde032c618c WHIRLPOOL 7118e57ca9a394de3b37166bb2c4f4d398fdf744caa0803ef9f1470db7020d999f795ca816a5a70db2b59b64db7225df2dd9366fd329ca34d52b5e4611fd5d21
diff --git a/app-crypt/ccid/ccid-1.4.26.ebuild b/app-crypt/ccid/ccid-1.4.26.ebuild
new file mode 100644
index 00000000000..651f1f593fe
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.26.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+STUPID_NUM="4205"
+
+inherit eutils toolchain-funcs udev autotools-utils
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
+SRC_URI="http://alioth.debian.org/frs/download.php/file/${STUPID_NUM}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="twinserial kobil-midentity +usb"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.8.3
+ usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( virtual/pkgconfig )"
+
+DOCS=( README AUTHORS )
+
+src_configure() {
+ local myeconfargs=(
+ LEX=:
+ $(use_enable twinserial)
+ $(use_enable usb libusb)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use kobil-midentity && autotools-utils_src_compile contrib/Kobil_mIDentity_switch
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use kobil-midentity; then
+ dosbin "${BUILD_DIR}"/contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
+ doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
+ fi
+
+ if use kernel_linux; then
+ # note: for eudev support, rules probably will always need to be
+ # installed to /usr
+
+ # ccid >=1.4.11 version changed the rules drastically in a minor
+ # release to no longer use the pcscd group. Using the old ones in
+ # the mean time.
+ udev_newrules "${FILESDIR}"/92_pcscd_ccid-2.rules 92-pcsc-ccid.rules
+
+ # disable Kobil_mIDentity_switch udev rule with USE=-kobil-midentity
+ if ! use kobil-midentity; then
+ sed \
+ -e '/Kobil_mIDentity_switch/s/^/#/' \
+ -i "${D}/$(get_udevdir)"/rules.d/92-pcsc-ccid.rules || die
+ fi
+
+ fi
+}