summaryrefslogtreecommitdiff
path: root/app-crypt/ccid
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 02:49:34 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 03:30:53 +0200
commitd2a1d6aaa4d4e70d2657f299768477bdd083d208 (patch)
treea25744fb8dccee79b219826c0e1f6cf26063a28d /app-crypt/ccid
parentb8596b477e23f7f7a607354070a50c36ceeedb3b (diff)
downloadgentoo-d2a1d6aaa4d4e70d2657f299768477bdd083d208.tar.gz
gentoo-d2a1d6aaa4d4e70d2657f299768477bdd083d208.tar.xz
app-crypt/ccid: eapi bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-crypt/ccid')
-rw-r--r--app-crypt/ccid/ccid-1.4.26.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/app-crypt/ccid/ccid-1.4.26.ebuild b/app-crypt/ccid/ccid-1.4.26.ebuild
index 651f1f593fe..3f8d55ed380 100644
--- a/app-crypt/ccid/ccid-1.4.26.ebuild
+++ b/app-crypt/ccid/ccid-1.4.26.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
STUPID_NUM="4205"
-inherit eutils toolchain-funcs udev autotools-utils
+inherit eutils toolchain-funcs udev
DESCRIPTION="CCID free software driver"
HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
@@ -25,25 +25,22 @@ DEPEND="${RDEPEND}
DOCS=( README AUTHORS )
src_configure() {
- local myeconfargs=(
- LEX=:
- $(use_enable twinserial)
+ econf \
+ LEX=: \
+ $(use_enable twinserial) \
$(use_enable usb libusb)
- )
-
- autotools-utils_src_configure
}
src_compile() {
- autotools-utils_src_compile
- use kobil-midentity && autotools-utils_src_compile contrib/Kobil_mIDentity_switch
+ default
+ use kobil-midentity && emake -C contrib/Kobil_mIDentity_switch
}
src_install() {
- autotools-utils_src_install
+ default
if use kobil-midentity; then
- dosbin "${BUILD_DIR}"/contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
+ dosbin contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
fi