summaryrefslogtreecommitdiff
path: root/app-crypt/certbot
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-05-20 22:35:41 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-05-20 22:35:41 +0200
commitf0aa19e1c2e5b304e594819ee3a4f0172a7053c1 (patch)
treee7626caec326ddd268ba0a38fd4934ffcd14b100 /app-crypt/certbot
parent97cf053bcb5d64aaaa8616d9f1791cc066f32fcd (diff)
downloadgentoo-f0aa19e1c2e5b304e594819ee3a4f0172a7053c1.tar.gz
gentoo-f0aa19e1c2e5b304e594819ee3a4f0172a7053c1.tar.xz
app-crypt/certbot: Move package from app-crypt/letsencrypt
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt/certbot')
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-0.6.0.ebuild47
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild47
-rw-r--r--app-crypt/certbot/metadata.xml11
4 files changed, 106 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
new file mode 100644
index 00000000000..2375ee53041
--- /dev/null
+++ b/app-crypt/certbot/Manifest
@@ -0,0 +1 @@
+DIST certbot-0.6.0.tar.gz 686826 SHA256 58eaa6be4ae90af07d682296e42dbac924b5602c51002445059596313e182a09 SHA512 966fdbff13ac9651ebb5fafae86a58a45538d57a43eb6d157358bbecef4286634bb61dd13b94e0ca5b006980a35cc5fe55b4a12efdeadc2530653d844516c926 WHIRLPOOL 0bd424395b9002a04f6c900b208aea758f74e9864d75f6aa87fc30573f046c63f9791aa8bcce0a5452831192d1579e9b52fda5ed77befd6e4f361dab976d6369
diff --git a/app-crypt/certbot/certbot-0.6.0.ebuild b/app-crypt/certbot/certbot-0.6.0.ebuild
new file mode 100644
index 00000000000..df9530cff4d
--- /dev/null
+++ b/app-crypt/certbot/certbot-0.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.10.0[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pythondialog-3.2.2:python-2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w ${PN}/tests || die
+}
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
new file mode 100644
index 00000000000..df9530cff4d
--- /dev/null
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.10.0[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pythondialog-3.2.2:python-2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w ${PN}/tests || die
+}
diff --git a/app-crypt/certbot/metadata.xml b/app-crypt/certbot/metadata.xml
new file mode 100644
index 00000000000..8669732b761
--- /dev/null
+++ b/app-crypt/certbot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">certbot/certbot</remote-id>
+ </upstream>
+</pkgmetadata>