summaryrefslogtreecommitdiff
path: root/app-crypt/debian-archive-keyring
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-05-21 16:19:26 +0200
committerSebastian Pipping <sping@gentoo.org>2017-05-21 16:21:19 +0200
commite27e066be274861b127297b6a749975e3d355d80 (patch)
tree11213252fc63a96a06cb73d51e46bad316132aa2 /app-crypt/debian-archive-keyring
parent21b1034b4b7333aa0c55305ac7e1c595b2d7ce10 (diff)
downloadgentoo-e27e066be274861b127297b6a749975e3d355d80.tar.gz
gentoo-e27e066be274861b127297b6a749975e3d355d80.tar.xz
app-crypt/debian-archive-keyring: Save compiling non-code (bug #614932)
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-crypt/debian-archive-keyring')
-rw-r--r--app-crypt/debian-archive-keyring/Manifest2
-rw-r--r--app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild14
-rw-r--r--app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch36
3 files changed, 8 insertions, 44 deletions
diff --git a/app-crypt/debian-archive-keyring/Manifest b/app-crypt/debian-archive-keyring/Manifest
index 1677b987809..405e61b414c 100644
--- a/app-crypt/debian-archive-keyring/Manifest
+++ b/app-crypt/debian-archive-keyring/Manifest
@@ -1 +1 @@
-DIST debian-archive-keyring_2014.3.tar.xz 61380 SHA256 46be978ec2f72b0277d9e71bda30ea1b2b9aa00b1952cb35e8b22a2c016f5e22 SHA512 6ae189976dca807705c76fab16d8219f042dc3c8a12e6f12872cc6faa8941831392d0b97a34367c24855f98621ba2eb56e71440291bc12a5cecc05ea2b5622ab WHIRLPOOL 94344189e21e42333e5f131aada6bda02d7f9bf72c809df00ef6e570810524bd9b9f4e79b55237b224155fb651205a60848ce037e4dae138b6449e97c1ace9ea
+DIST debian-archive-keyring_2014.3_all.deb 40060 SHA256 017a2fba215cd64612891f5aa02546be5c0e30923a66672f889867cc6dd8d3a0 SHA512 7a24596f250eafb6e62d19523cd13c3b1809bea3f694bd92f3d427f67cd840e0292200e6b033b5c5c5cf41ab40233ae17d133a846be483afa1da3b67cac72931 WHIRLPOOL a533e18402fd85e08f4ce1e96b6c9c79e8ec844afdc588557cfd730cd5cc8b36e711e4629e9d74c7f36b129d02c711b24f8626a00489775c8ef7bd29c567ce0e
diff --git a/app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild b/app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild
index fde180a215f..7f78c2c6b24 100644
--- a/app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild
+++ b/app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild
@@ -3,19 +3,19 @@
EAPI=6
+inherit unpacker
+
DESCRIPTION="GnuPG archive keys of the Debian archive"
HOMEPAGE="http://packages.debian.org/sid/debian-archive-keyring"
-SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.xz"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}_all.deb"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="app-crypt/jetring"
-
-MAKEOPTS+=' -j1'
+S="${WORKDIR}"
-PATCHES=(
- "${FILESDIR}"/${P}-order.patch
-)
+src_install() {
+ doins -r .
+}
diff --git a/app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch b/app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch
deleted file mode 100644
index 59b2412bf99..00000000000
--- a/app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From fdf28f2cb17ae0bf8fac569335dabdbc9e83a452 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Sat, 8 Apr 2017 14:55:06 +0200
-Subject: [PATCH] Ensure verification starts after build
-
----
- Makefile | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 0952a5d..b722226 100644
---- a/Makefile
-+++ b/Makefile
-@@ -3,7 +3,12 @@ TMPRING := trusted.gpg/build-area
-
- GPG_OPTIONS := --no-options --no-default-keyring --no-auto-check-trustdb --trustdb-name ./trustdb.gpg
-
--build: verify-indices keyrings/debian-archive-keyring.gpg keyrings/debian-archive-removed-keys.gpg verify-results $(TRUSTED-LIST)
-+all:
-+ $(MAKE) build verify
-+
-+build: keyrings/debian-archive-keyring.gpg keyrings/debian-archive-removed-keys.gpg $(TRUSTED-LIST)
-+
-+verify: verify-indices verify-results
-
- verify-indices: keyrings/team-members.gpg
- gpg ${GPG_OPTIONS} \
-@@ -61,4 +66,4 @@ install: build
- install -d $(DESTDIR)/etc/apt/trusted.gpg.d/
- cp $(shell find trusted.gpg/ -name '*.gpg' -type f) $(DESTDIR)/etc/apt/trusted.gpg.d/
-
--.PHONY: verify-indices verify-results clean build install
-+.PHONY: all verify verify-indices verify-results clean build install
---
-2.12.2
-