summaryrefslogtreecommitdiff
path: root/app-crypt/dirmngr
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/dirmngr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/dirmngr')
-rw-r--r--app-crypt/dirmngr/Manifest1
-rw-r--r--app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild41
-rw-r--r--app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch17
-rw-r--r--app-crypt/dirmngr/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/dirmngr/Manifest b/app-crypt/dirmngr/Manifest
new file mode 100644
index 00000000000..6b6bad27ca1
--- /dev/null
+++ b/app-crypt/dirmngr/Manifest
@@ -0,0 +1 @@
+DIST dirmngr-1.1.1.tar.bz2 566929 SHA256 d2280b8c314db80cdaf101211a47826734443436f5c3545cc1b614c50eaae6ff SHA512 922512f22853c49cf291207c81862c68ba51c89646036288592d6b2f57709d35ac53f9f550569986c04daec20403ab8ec85b08893443af417950916b869c8419 WHIRLPOOL 84a174d42418723e346c7af8d9bb9aa12e4602cbba9510f492ef10d29f4900768ede986d2c7c93cee129ce03e5aeca08357490ec050b54e1250e2e4b36150617
diff --git a/app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild b/app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild
new file mode 100644
index 00000000000..d9c8bd8d558
--- /dev/null
+++ b/app-crypt/dirmngr/dirmngr-1.1.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="DirMngr is a daemon to handle CRL and certificate requests for GnuPG"
+HOMEPAGE="http://www.gnupg.org/download/index.en.html#dirmngr"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 sparc x86"
+IUSE="nls"
+
+RDEPEND=">=net-nds/openldap-2.1.26
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libgcrypt-1.4.0:0
+ >=dev-libs/libksba-1.0.2
+ >=dev-libs/pth-1.3.7
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ >=dev-libs/libassuan-2
+ nls? ( >=sys-devel/gettext-0.12.1 )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-pth.patch"
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}" $(use_enable nls) \
+ LDAPLIBS="-lldap -llber"
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
diff --git a/app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch b/app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch
new file mode 100644
index 00000000000..862458ed1db
--- /dev/null
+++ b/app-crypt/dirmngr/files/dirmngr-1.1.1-pth.patch
@@ -0,0 +1,17 @@
+Index: src/dirmngr.c
+===================================================================
+--- src/dirmngr.c (revision 348)
++++ src/dirmngr.c (working copy)
+@@ -665,8 +665,11 @@
+ the option parsing may need services of the libraries. */
+
+ /* Libgcrypt requires us to register the threading model first.
+- Note that this will also do the pth_init. */
++ Note that this will also do the pth_init for libgcrypt < 1.6 */
+
++#if GCRYPT_VERSION_NUMBER >= 0x010600
++ pth_init ();
++#endif
+ /* Init Libgcrypt. */
+ rc = gcry_control (GCRYCTL_SET_THREAD_CBS, &gcry_threads_pth);
+ if (rc)
diff --git a/app-crypt/dirmngr/metadata.xml b/app-crypt/dirmngr/metadata.xml
new file mode 100644
index 00000000000..d68fe974c15
--- /dev/null
+++ b/app-crypt/dirmngr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+</pkgmetadata>