summaryrefslogtreecommitdiff
path: root/app-crypt/etcd-ca
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/etcd-ca
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/etcd-ca')
-rw-r--r--app-crypt/etcd-ca/Manifest2
-rw-r--r--app-crypt/etcd-ca/etcd-ca-0_p20140903.ebuild38
-rw-r--r--app-crypt/etcd-ca/etcd-ca-0_p20150423-r1.ebuild38
-rw-r--r--app-crypt/etcd-ca/etcd-ca-0_p20150423.ebuild38
-rw-r--r--app-crypt/etcd-ca/metadata.xml13
5 files changed, 129 insertions, 0 deletions
diff --git a/app-crypt/etcd-ca/Manifest b/app-crypt/etcd-ca/Manifest
new file mode 100644
index 00000000000..ba22e275652
--- /dev/null
+++ b/app-crypt/etcd-ca/Manifest
@@ -0,0 +1,2 @@
+DIST etcd-ca-0_p20140903.zip 1178338 SHA256 5da9f7afad6dd373d96c5d36dd30e9f43cfc8fc2359bbf2d0c6a864fff139f81 SHA512 f421be2c835e7ed701f698d8a48cf25fe011ba3a831ff8fa3a80f5f074f6b70fed7f71d64c488cce5e12af8b8ae29685a1b19f8f2cd487954019d483d90f5e1c WHIRLPOOL 8f1db212877eb522818a96b45e21946e27fac716acfe924ea45c0b8f20b253905eccfeffa1fdf47c582f6cc8866da812462cd71e2ddc6c5abc969f71737cf749
+DIST etcd-ca-0_p20150423.tar.gz 55031 SHA256 53e5083db3bee32a991a118be0386bfeadafc3173a707941c3a12284a7f97abc SHA512 8c7ecb80e056da77997283ff2defb6df9a9acef250b0fac8e18c2bca71cccfedf6d782b7c9bf6491574d88ac5fa358f9bc5f540aa718a2470655d75f2f54fff4 WHIRLPOOL 3f7b5a77787f6ed6474fb01bfcf02d394616d609d8cb815086b730499eb7293c9125c09abfa4a10a2c6ca375176a82d75fb3fe304fc1f9f53385f9b552ebff12
diff --git a/app-crypt/etcd-ca/etcd-ca-0_p20140903.ebuild b/app-crypt/etcd-ca/etcd-ca-0_p20140903.ebuild
new file mode 100644
index 00000000000..4c2eed67060
--- /dev/null
+++ b/app-crypt/etcd-ca/etcd-ca-0_p20140903.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="A simple certificate manager written in Go. Easy to use with limited capability"
+HOMEPAGE="https://github.com/coreos/etcd-ca"
+EGIT_COMMIT="812f3626796be16d9db052720ce9c54f5a40bb26"
+SRC_URI="${HOMEPAGE}/archive/${EGIT_COMMIT}.zip -> ${P}.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc"
+DEPEND=">=dev-lang/go-1.2"
+RDEPEND=""
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+src_prepare() {
+ sed -e "s:^\(go install\)\(.*\)$:\\1 -x -ldflags=\"-v -linkmode=external -extldflags '${LDFLAGS}'\" \\2:" \
+ -i build || die
+}
+
+src_compile() {
+ CGO_CFLAGS="${CFLAGS}" ./build || die
+}
+
+# go tool: no such tool "cover"; to install:
+# go get code.google.com/p/go.tools/cmd/cover
+#src_test() {
+# ./test || die
+#}
+
+src_install() {
+ dobin "${S}"/bin/${PN}
+ dodoc README.md
+ use doc && dodoc -r Documentation
+}
diff --git a/app-crypt/etcd-ca/etcd-ca-0_p20150423-r1.ebuild b/app-crypt/etcd-ca/etcd-ca-0_p20150423-r1.ebuild
new file mode 100644
index 00000000000..3209ff0718f
--- /dev/null
+++ b/app-crypt/etcd-ca/etcd-ca-0_p20150423-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="A simple certificate manager written in Go. Easy to use with limited capability"
+HOMEPAGE="https://github.com/coreos/etcd-ca"
+EGIT_COMMIT="31fef42f75294cf8bf1e7facf82648de0c2d87a3"
+SRC_URI="${HOMEPAGE}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc"
+DEPEND=">=dev-lang/go-1.2:="
+RDEPEND=""
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+src_prepare() {
+ sed -e "s:^\(go install\)\(.*\)$:\\1 -x -ldflags=\"-v -linkmode=external -extldflags '${LDFLAGS}'\" \\2:" \
+ -i build || die
+}
+
+src_compile() {
+ CGO_CFLAGS="${CFLAGS}" ./build || die
+}
+
+# go tool: no such tool "cover"; to install:
+# go get code.google.com/p/go.tools/cmd/cover
+#src_test() {
+# ./test || die
+#}
+
+src_install() {
+ dobin "${S}"/bin/${PN}
+ dodoc README.md
+ use doc && dodoc -r Documentation
+}
diff --git a/app-crypt/etcd-ca/etcd-ca-0_p20150423.ebuild b/app-crypt/etcd-ca/etcd-ca-0_p20150423.ebuild
new file mode 100644
index 00000000000..78d825dc4f8
--- /dev/null
+++ b/app-crypt/etcd-ca/etcd-ca-0_p20150423.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="A simple certificate manager written in Go. Easy to use with limited capability"
+HOMEPAGE="https://github.com/coreos/etcd-ca"
+EGIT_COMMIT="31fef42f75294cf8bf1e7facf82648de0c2d87a3"
+SRC_URI="${HOMEPAGE}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc"
+DEPEND=">=dev-lang/go-1.2"
+RDEPEND=""
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+src_prepare() {
+ sed -e "s:^\(go install\)\(.*\)$:\\1 -x -ldflags=\"-v -linkmode=external -extldflags '${LDFLAGS}'\" \\2:" \
+ -i build || die
+}
+
+src_compile() {
+ CGO_CFLAGS="${CFLAGS}" ./build || die
+}
+
+# go tool: no such tool "cover"; to install:
+# go get code.google.com/p/go.tools/cmd/cover
+#src_test() {
+# ./test || die
+#}
+
+src_install() {
+ dobin "${S}"/bin/${PN}
+ dodoc README.md
+ use doc && dodoc -r Documentation
+}
diff --git a/app-crypt/etcd-ca/metadata.xml b/app-crypt/etcd-ca/metadata.xml
new file mode 100644
index 00000000000..6a37ab4bc32
--- /dev/null
+++ b/app-crypt/etcd-ca/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <bugs-to>https://github.com/coreos/etcd-ca/issues</bugs-to>
+ <changelog>https://github.com/coreos/etcd-ca/commits/master</changelog>
+ <doc>https://github.com/coreos/etcd-ca/blob/master/README.md</doc>
+ <remote-id type="github">coreos/etcd-ca</remote-id>
+ </upstream>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>