summaryrefslogtreecommitdiff
path: root/app-crypt/gpgme
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-10-19 08:25:36 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-10-19 08:27:43 +0300
commitecdfeec4d3d5a1ba5ff08ab67f25b2e817ab3e74 (patch)
treef52932890abeb4d3a87dc110246b7147a2a3b176 /app-crypt/gpgme
parentbf52feeda5984d5ed1f34dfb9a90fc95f670add3 (diff)
downloadgentoo-ecdfeec4d3d5a1ba5ff08ab67f25b2e817ab3e74.tar.gz
gentoo-ecdfeec4d3d5a1ba5ff08ab67f25b2e817ab3e74.tar.xz
app-crypt/gpgme: fix minor issues
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/gpgme-1.7.1.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/app-crypt/gpgme/gpgme-1.7.1.ebuild b/app-crypt/gpgme/gpgme-1.7.1.ebuild
index 9d190a00e99..de6760d1f84 100644
--- a/app-crypt/gpgme/gpgme-1.7.1.ebuild
+++ b/app-crypt/gpgme/gpgme-1.7.1.ebuild
@@ -7,7 +7,7 @@ EAPI="6"
PYTHON_COMPAT=( python2_7 python3_{3,4} )
DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 eutils qmake-utils
+inherit distutils-r1 eutils qmake-utils
DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
@@ -16,7 +16,7 @@ SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="1/11" # subslot = soname major version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="common-lisp static-libs cxx python qt5 test"
+IUSE="common-lisp static-libs cxx python qt5"
RDEPEND="app-crypt/gnupg
>=dev-libs/libassuan-2.0.2
@@ -30,9 +30,7 @@ RDEPEND="app-crypt/gnupg
#doc? ( app-doc/doxygen[dot] )
DEPEND="${RDEPEND}
python? ( dev-lang/swig )
- qt5? (
- test? ( dev-qt/qttest:5 )
- )"
+ qt5? ( dev-qt/qttest:5 )"
REQUIRED_USE="qt5? ( cxx )"
@@ -50,7 +48,6 @@ do_python() {
src_prepare() {
default
- eautoreconf
do_python
}
@@ -61,7 +58,7 @@ src_configure() {
if use qt5; then
languages+=( "qt" )
#use doc ||
- export DOXYGEN=
+ export DOXYGEN=true
export MOC="$(qt5_get_bindir)/moc"
fi