summaryrefslogtreecommitdiff
path: root/app-crypt/ima-evm-utils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/ima-evm-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/ima-evm-utils')
-rw-r--r--app-crypt/ima-evm-utils/Manifest2
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-0.2.ebuild33
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-0.8.ebuild33
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild22
-rw-r--r--app-crypt/ima-evm-utils/metadata.xml14
5 files changed, 104 insertions, 0 deletions
diff --git a/app-crypt/ima-evm-utils/Manifest b/app-crypt/ima-evm-utils/Manifest
new file mode 100644
index 00000000000..58e6011e48a
--- /dev/null
+++ b/app-crypt/ima-evm-utils/Manifest
@@ -0,0 +1,2 @@
+DIST ima-evm-utils-0.2.tar.gz 16329 SHA256 ca8c238562c205f265ff76db7af15df90eea7335db82f6c2fe82def34315aba6 SHA512 44d5ead01d0d1241d743a8545a619308a1988f2188384571d7d37dca567598f46d1d7d8b8a6ba3fdaf5b5e980f4c8a80f1c098ec4dadf082393a727f7a266229 WHIRLPOOL db21f3cddd0f21f23605c3abed0b2ea9f864b63c7715605bdd24c0345527923d51684f57c7d0b18a6eb5590882530e2f13d52aa3d908353d3c69657b4e499a32
+DIST ima-evm-utils-0.8.tar.gz 32025 SHA256 4d9b467ba31305dd815c56ddda5969db45133c7bd14f4a5356df58ed35221cf1 SHA512 cfa90963426c9adfaa3b61e31c1b63d87407a1dfadd39d4c00f5c16b2b312d7535159c84c7f1854bb143147b5b097ef41dde22f8bba30555eecd8ed0255f3630 WHIRLPOOL 32d47f8f23d4a28ae96178ac443ce9ddff102ccfded22f06796ad23bdff375272cc3f2d4c92eb6bc2d5b9df92fde45e5af4161f20ea9eb1ebc8e0ef2c5c83005
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-0.2.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-0.2.ebuild
new file mode 100644
index 00000000000..d99d1591aa0
--- /dev/null
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Supporting tools for IMA and EVM"
+HOMEPAGE="http://linux-ima.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-ima/${P}.tar.gz"
+
+DEPEND="sys-apps/keyutils"
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i 's:pkglib_PROGRAMS:pkglibexec_PROGRAMS:g' tests/Makefile.am
+ sed -i 's:pkglib_SCRIPTS:pkglibexec_SCRIPTS:g' tests/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-0.8.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-0.8.ebuild
new file mode 100644
index 00000000000..70bd5051656
--- /dev/null
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Supporting tools for IMA and EVM"
+HOMEPAGE="http://linux-ima.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-ima/${P}.tar.gz"
+
+DEPEND="sys-apps/keyutils"
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i 's:pkglib_PROGRAMS:pkglibexec_PROGRAMS:g' tests/Makefile.am
+ sed -i 's:pkglib_SCRIPTS:pkglibexec_SCRIPTS:g' tests/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
new file mode 100644
index 00000000000..f46ca06ee74
--- /dev/null
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://linux-ima.git.sourceforge.net/gitroot/linux-ima/ima-evm-utils.git"
+EGIT_BOOTSTRAP="autogen.sh"
+
+inherit git-2 eutils
+
+DESCRIPTION="Supporting tools for IMA and EVM"
+HOMEPAGE="http://linux-ima.sourceforge.net"
+SRC_URI=""
+
+DEPEND="sys-apps/keyutils"
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
diff --git a/app-crypt/ima-evm-utils/metadata.xml b/app-crypt/ima-evm-utils/metadata.xml
new file mode 100644
index 00000000000..5f04ab17905
--- /dev/null
+++ b/app-crypt/ima-evm-utils/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>hardened</herd>
+<maintainer>
+<email>swift@gentoo.org</email>
+<name>Sven Vermeulen</name>
+<description>Maintainer</description>
+</maintainer>
+<longdescription lang="en">
+Supporting tools for IMA and EVM
+</longdescription>
+</pkgmetadata>
+