summaryrefslogtreecommitdiff
path: root/app-crypt/kbfs
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2017-12-27 07:31:55 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2017-12-27 07:38:18 -0700
commite712457ed85b518489070d27b00720b2dbba2744 (patch)
treebf3d8c079a3d846ae28faf62883ae101083ccbb5 /app-crypt/kbfs
parentfbd6ce1fdc278e0de981c74b09b71f417e704b1b (diff)
downloadgentoo-e712457ed85b518489070d27b00720b2dbba2744.tar.gz
gentoo-e712457ed85b518489070d27b00720b2dbba2744.tar.xz
app-crypt/keybase: Version bump keybase-1.0.39
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-crypt/kbfs')
-rw-r--r--app-crypt/kbfs/kbfs-1.0.36.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/kbfs/kbfs-1.0.36.ebuild b/app-crypt/kbfs/kbfs-1.0.36.ebuild
new file mode 100644
index 00000000000..b084faeb8f1
--- /dev/null
+++ b/app-crypt/kbfs/kbfs-1.0.36.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Keybase Filesystem (KBFS)"
+HOMEPAGE="https://keybase.io/docs/kbfs"
+EGIT_REPO_URI="https://github.com/keybase/kbfs.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="git"
+
+DEPEND="
+ >=dev-lang/go-1.6:0
+ >=app-crypt/keybase-1.0.17
+ "
+RDEPEND="
+ app-crypt/gnupg
+ sys-fs/fuse
+ "
+
+S="${WORKDIR}/src/github.com/keybase/kbfs"
+
+src_unpack() {
+ git-r3_src_unpack
+ mkdir -p "$(dirname "${S}")" || die
+ ln -s "${WORKDIR}/${P}" "${S}" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/kbfsfuse" \
+ github.com/keybase/kbfs/kbfsfuse
+ use git && \
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/git-remote-keybase" \
+ github.com/keybase/kbfs/kbfsgit/git-remote-keybase
+}
+
+src_install() {
+ dobin "${T}/kbfsfuse"
+ use git && \
+ dobin "${T}/git-remote-keybase"
+}