summaryrefslogtreecommitdiff
path: root/app-crypt/libmd
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-24 07:37:38 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-24 07:39:54 +0200
commitade95aff9f80ab44772817f6a997d8e57b06dca1 (patch)
tree0c21887a479b38151e6e4852adaf66fcfc73193f /app-crypt/libmd
parent3e868d1a0b7546c44c2c47bb8c695b456350caa1 (diff)
downloadgentoo-ade95aff9f80ab44772817f6a997d8e57b06dca1.tar.gz
gentoo-ade95aff9f80ab44772817f6a997d8e57b06dca1.tar.xz
app-crypt/libmd: Version 1.0.1
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-crypt/libmd')
-rw-r--r--app-crypt/libmd/Manifest1
-rw-r--r--app-crypt/libmd/libmd-1.0.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/libmd/Manifest b/app-crypt/libmd/Manifest
index 2144e6d299f..cbd59f348c4 100644
--- a/app-crypt/libmd/Manifest
+++ b/app-crypt/libmd/Manifest
@@ -1 +1,2 @@
DIST libmd-1.0.0.tar.xz 254852 BLAKE2B af0d3c645a18262965e708d678cb30c7ed168af8055885b08084fafd7299e9aaea95efb8437ffa756e43c5bb75fac99af067c6a560f3bb2b8b93ee889d5e664b SHA512 54c3cae1308f7686a1f642d25ae5d8cfb0fce2b98b33cf5e2891682893715c7de7e9700c70a6bd7e4ab4cf7f54c87643b259319e09e03f529b70d273477fc8be
+DIST libmd-1.0.1.tar.xz 257372 BLAKE2B e954ab6b1247952abcf6964d8d714c2a47a644e206a455db547a0159a97ebbc323cf1258a24c744cea3106f267f1a319a689fe545b672580f4e134d96cc7cb3d SHA512 6f343101f9ad8f927d862e6bae948d35ba596ecfd375c255fefb86efc621cf6e9de3597770ad66e0a48e8f4ea018df78debb571ea6746a7457d8900fec87069b
diff --git a/app-crypt/libmd/libmd-1.0.1.ebuild b/app-crypt/libmd/libmd-1.0.1.ebuild
new file mode 100644
index 00000000000..fb6a517f9fb
--- /dev/null
+++ b/app-crypt/libmd/libmd-1.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/libmd.la || die
+ fi
+}