summaryrefslogtreecommitdiff
path: root/app-crypt/libscrypt
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/libscrypt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/libscrypt')
-rw-r--r--app-crypt/libscrypt/Manifest2
-rw-r--r--app-crypt/libscrypt/libscrypt-1.19.ebuild29
-rw-r--r--app-crypt/libscrypt/libscrypt-1.20.ebuild29
-rw-r--r--app-crypt/libscrypt/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/app-crypt/libscrypt/Manifest b/app-crypt/libscrypt/Manifest
new file mode 100644
index 00000000000..c767d0c8b83
--- /dev/null
+++ b/app-crypt/libscrypt/Manifest
@@ -0,0 +1,2 @@
+DIST libscrypt-1.19.tar.gz 18208 SHA256 8f398677b2b43e21423b800156b3379f3cb0d314e70eec2eb2e83a012bce854f SHA512 decf4fe6eb83d6a9ddd71cd9b9f4f9232bbadc8a7dc4c62aa737b162fdb97a18e6a8b3ac314c0900830b151c1b77a8dc00ffd0e47e47c425490ee4c43a21a735 WHIRLPOOL 877bcc095fedabf023bdd1eb921625889afdaf20512ee93135b602d75b12686317efe2e63b5f115efb7d846f2a021cab84a0ce5791bcaa1abb931710895bbcfc
+DIST libscrypt-1.20.tar.gz 18451 SHA256 6074add2170b7d00e080fe3a58d3dec76850a4f272d488f5e8cc3c4acb6d8e21 SHA512 c7db096c740681c328d4c156372147331c0441906c1f17656a8ddd8345348091295749c4e3105bf26106f826327acac9bda97efec4ce50ac56d64f903c59e9af WHIRLPOOL 5d854936f955fbc08ec7d31e89396d3198ea58cac326ea8ceaedcc360e412cefc9e75b49a959870924cabe79ccf14453209cf450ff0256873c1de744f65706ac
diff --git a/app-crypt/libscrypt/libscrypt-1.19.ebuild b/app-crypt/libscrypt/libscrypt-1.19.ebuild
new file mode 100644
index 00000000000..830211537fb
--- /dev/null
+++ b/app-crypt/libscrypt/libscrypt-1.19.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Shared library to impliment the scrypt algorithm. See http://www.tarsnap.com/scrypt.html."
+HOMEPAGE="https://github.com/technion/libscrypt"
+SRC_URI="https://github.com/technion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ export PREFIX=/usr
+ export LIBDIR=${PREFIX}/$(get_libdir)
+ export CC=$(tc-getCC)
+ export CFLAGS="$CFLAGS -fPIC"
+ export LDFLAGS="$LDFLAGS -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version"
+ export CFLAGS_EXTRA=
+ emake
+}
diff --git a/app-crypt/libscrypt/libscrypt-1.20.ebuild b/app-crypt/libscrypt/libscrypt-1.20.ebuild
new file mode 100644
index 00000000000..6e5a3038f64
--- /dev/null
+++ b/app-crypt/libscrypt/libscrypt-1.20.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Shared library to impliment the scrypt algorithm. See http://www.tarsnap.com/scrypt.html."
+HOMEPAGE="https://github.com/technion/libscrypt"
+SRC_URI="https://github.com/technion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ export PREFIX=/usr
+ export LIBDIR=${PREFIX}/$(get_libdir)
+ export CC=$(tc-getCC)
+ export CFLAGS="$CFLAGS -fPIC"
+ export LDFLAGS="$LDFLAGS -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version"
+ export CFLAGS_EXTRA=
+ emake
+}
diff --git a/app-crypt/libscrypt/metadata.xml b/app-crypt/libscrypt/metadata.xml
new file mode 100644
index 00000000000..5afd4895b47
--- /dev/null
+++ b/app-crypt/libscrypt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">technion/libscrypt</remote-id>
+ </upstream>
+</pkgmetadata>