summaryrefslogtreecommitdiff
path: root/app-crypt/manuale/manuale-1.1.0.ebuild
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-04 23:53:10 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-04 23:53:10 +0100
commitafc163534e56ec53f3a40d6328fa42dc570b0734 (patch)
tree8d1bb3afdca509b1220d701d1d353ee5bec6aee0 /app-crypt/manuale/manuale-1.1.0.ebuild
parent4ece7dee3ee7e8f5d4dadc9406037eee3064dfd4 (diff)
downloadgentoo-afc163534e56ec53f3a40d6328fa42dc570b0734.tar.gz
gentoo-afc163534e56ec53f3a40d6328fa42dc570b0734.tar.xz
app-crypt/manuale: Version bump to 1.1.0
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-crypt/manuale/manuale-1.1.0.ebuild')
-rw-r--r--app-crypt/manuale/manuale-1.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-crypt/manuale/manuale-1.1.0.ebuild b/app-crypt/manuale/manuale-1.1.0.ebuild
new file mode 100644
index 00000000000..e6e9f810bb4
--- /dev/null
+++ b/app-crypt/manuale/manuale-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fully manual Let's Encrypt client"
+HOMEPAGE="https://github.com/veeti/manuale"
+SRC_URI="https://github.com/veeti/manuale/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+DOCS=( README.md CHANGELOG.md)