summaryrefslogtreecommitdiff
path: root/app-crypt/rhash
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-09-02 13:36:39 +0100
committerJames Le Cuirot <chewi@gentoo.org>2017-09-02 13:38:40 +0100
commit2b37168745eee2cc9ec0defacab07bae17ea771a (patch)
tree51dc45af225ff917d04334c52f97e1680aa24d70 /app-crypt/rhash
parent8414705ae146126e4745b343cd33e71a405cb166 (diff)
downloadgentoo-2b37168745eee2cc9ec0defacab07bae17ea771a.tar.gz
gentoo-2b37168745eee2cc9ec0defacab07bae17ea771a.tar.xz
app-crypt/rhash: Use elibc USE flags instead of CHOST for fixes
This is more accurate. Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'app-crypt/rhash')
-rw-r--r--app-crypt/rhash/rhash-1.3.5.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-crypt/rhash/rhash-1.3.5.ebuild b/app-crypt/rhash/rhash-1.3.5.ebuild
index e1ea23cd4fc..77b468a64c5 100644
--- a/app-crypt/rhash/rhash-1.3.5.ebuild
+++ b/app-crypt/rhash/rhash-1.3.5.ebuild
@@ -27,7 +27,7 @@ src_prepare() {
# Install /etc stuff inside the Prefix
sed -i -e 's:\$(DESTDIR)/etc:\$(DESTDIR)/$(SYSCONFDIR):g' Makefile || die
- if [[ ${CHOST} == *-darwin* ]] ; then
+ if use elibc_Darwin ; then
local ver_script='-Wl,--version-script,exports.sym,-soname,$(SONAME)'
local install_name='-install_name $(LIBDIR)/$(SONAME)'
sed -i -e '/^\(SONAME\|SHAREDLIB\)/s/\.so\.\([0-9]\+\)/.\1.dylib/' \
@@ -37,7 +37,7 @@ src_prepare() {
Makefile || die
fi
- if [[ ${CHOST} == *-solaris* ]] ; then
+ if use elibc_SunOS ; then
# https://sourceware.org/bugzilla/show_bug.cgi?id=12548
# skip the export.sym for now
sed -i -e 's/,--version-script,exports.sym//' librhash/Makefile || die
@@ -57,8 +57,8 @@ multilib_src_compile() {
$(use openssl && echo -ldl)
)
- [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] \
- && ADDLDFLAGS+=( $(use nls && echo -lintl) )
+ use elibc_Darwin || use elibc_SunOS &&
+ ADDLDFLAGS+=( $(use nls && echo -lintl) )
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" \
ADDCFLAGS="${ADDCFLAGS[*]}" ADDLDFLAGS="${ADDLDFLAGS[*]}" \