summaryrefslogtreecommitdiff
path: root/app-crypt/rhash
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-03-19 10:30:47 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-03-19 10:31:44 +0000
commit8659d46e313acd4bbc5515ab9e92a58a22064a69 (patch)
tree4fc96fa70b1d97cbca393602150687777dd2f9c1 /app-crypt/rhash
parent5902dd2c1d769270271363c9361d348091f2f1fc (diff)
downloadgentoo-8659d46e313acd4bbc5515ab9e92a58a22064a69.tar.gz
gentoo-8659d46e313acd4bbc5515ab9e92a58a22064a69.tar.xz
app-crypt/rhash: Fix missing headers and dash issue
I swear it installed the headers without this line at least some of the time. Yay for custom build systems. Closes: https://bugs.gentoo.org/650840 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-crypt/rhash')
-rw-r--r--app-crypt/rhash/files/rhash-1.3.6-no_echon.patch54
-rw-r--r--app-crypt/rhash/rhash-1.3.6-r1.ebuild (renamed from app-crypt/rhash/rhash-1.3.6.ebuild)4
2 files changed, 58 insertions, 0 deletions
diff --git a/app-crypt/rhash/files/rhash-1.3.6-no_echon.patch b/app-crypt/rhash/files/rhash-1.3.6-no_echon.patch
new file mode 100644
index 00000000000..9b25b29a89f
--- /dev/null
+++ b/app-crypt/rhash/files/rhash-1.3.6-no_echon.patch
@@ -0,0 +1,54 @@
+From c1776248a0b34a690e99ab9a7a814c34f78088ec Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 19 Mar 2018 10:47:13 +0100
+Subject: [PATCH] "echo -n" cannot be expected to work with every POSIX shell
+
+See "man 1p echo" section APPLICATION USAGE. This patch replaces "echo -n"
+with "printf '%s'".
+---
+ configure | 15 ++-------------
+ 1 file changed, 2 insertions(+), 13 deletions(-)
+
+diff --git a/configure b/configure
+index f480f7b..2a7d485 100755
+--- a/configure
++++ b/configure
+@@ -22,17 +22,6 @@ INSTALL_LIB_STATIC=auto
+ INSTALL_LIB_SHARED=auto
+ INSTALL_PKGCONFIGDIR="$PKG_INSTALLDIR"
+
+-case $(echo -n) in
+- -n) # SysV style
+- ECHO_N=
+- ECHO_C='\c'
+- ;;
+- *) # BSD style
+- ECHO_N='-n '
+- ECHO_C=
+- ;;
+-esac
+-
+ # display error message and exit
+ die () {
+ echo
+@@ -235,7 +224,7 @@ trap remove_tmpdir EXIT
+
+ str_concat()
+ {
+- echo ${ECHO_N} $@ ${ECHO_C}
++ printf '%s ' $@
+ }
+
+ yn_nonempty()
+@@ -246,7 +235,7 @@ yn_nonempty()
+ # Use this before starting a check
+ start_check() {
+ echo "============ Checking for $1 ============" >> "$TMPLOG"
+- echo ${ECHO_N} "Checking for $1 ... ${ECHO_C}"
++ printf '%s' "Checking for $1 ... "
+ res_comment=""
+ }
+
+--
+2.16.2
+
diff --git a/app-crypt/rhash/rhash-1.3.6.ebuild b/app-crypt/rhash/rhash-1.3.6-r1.ebuild
index 5680b2872ad..affa8241147 100644
--- a/app-crypt/rhash/rhash-1.3.6.ebuild
+++ b/app-crypt/rhash/rhash-1.3.6-r1.ebuild
@@ -23,6 +23,7 @@ S="${WORKDIR}/RHash-${PV}"
PATCHES=(
"${FILESDIR}"/unquote-cc.patch
+ "${FILESDIR}"/${P}-no_echon.patch
)
src_prepare() {
@@ -60,6 +61,9 @@ multilib_src_install() {
emake DESTDIR="${D}" -j1 \
install{,-lib-so-link,-pkg-config} \
$(use nls && echo install-gmo)
+
+ emake DESTDIR="${D}" -j1 \
+ -C lib${PN} install-headers
}
multilib_src_test() {