summaryrefslogtreecommitdiff
path: root/app-crypt/sgeps
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/sgeps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/sgeps')
-rw-r--r--app-crypt/sgeps/Manifest1
-rw-r--r--app-crypt/sgeps/metadata.xml13
-rw-r--r--app-crypt/sgeps/sgeps-0_pre15.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/sgeps/Manifest b/app-crypt/sgeps/Manifest
new file mode 100644
index 00000000000..eb7c188e864
--- /dev/null
+++ b/app-crypt/sgeps/Manifest
@@ -0,0 +1 @@
+DIST sgeps-0_pre15.tar.xz 3284 SHA256 cc178d541e60d45ead8ca1183a31d68c425ad518de0bd7115bdb5b02e0bfb395 SHA512 8ebf5f492baaf6ee7f93054a9afcc6c4318f755d85190ce2576c89a88908ee132283af873a37f60f611683689bc7e2e77903c95c6020c80ad916ebabf4583702 WHIRLPOOL cd972af6008f8a90dc2a33bc5e924471d49b980596eaad3b5db65f233cbbabe2d9b8e3fb98a5e893e90ea2b2ddc9f90dc08efb9fd6f9ec09be9e6d163e266b91
diff --git a/app-crypt/sgeps/metadata.xml b/app-crypt/sgeps/metadata.xml
new file mode 100644
index 00000000000..6356f38aa02
--- /dev/null
+++ b/app-crypt/sgeps/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>enrico.tagliavini@gmail.com</email>
+ <name>Enrico Tagliavini</name>
+ <description>Proxied co-maintainer</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-crypt/sgeps/sgeps-0_pre15.ebuild b/app-crypt/sgeps/sgeps-0_pre15.ebuild
new file mode 100644
index 00000000000..664bdf8f831
--- /dev/null
+++ b/app-crypt/sgeps/sgeps-0_pre15.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="simple GnuPG-encrypted password store written in perl"
+HOMEPAGE="http://roland.entierement.nu/blog/2010/01/22/simple-gnupg-encrypted-password-store.html"
+SRC_URI="http://dev.gentoo.org/~flameeyes/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="zsh-completion"
+
+RDEPEND="app-crypt/gnupg
+ dev-lang/perl
+ virtual/perl-Storable
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ dev-perl/Config-Simple
+ zsh-completion? ( app-shells/zsh )"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ dobin sgeps pwsafe2sgeps
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins zsh-completion _sgeps
+ fi
+}
+
+pkg_postinst() {
+ elog "To make use of sgeps, remember to create a configuration file as"
+ elog " ~/.config/sgeps.conf with these values:"
+ elog ""
+ elog "store = ~/somewhere/safe"
+ elog "keyid = 012345678"
+ elog ""
+ elog "If you want to use the --copy options you should install x11-misc/xclip"
+}