summaryrefslogtreecommitdiff
path: root/app-crypt/simp_le/simp_le-9999.ebuild
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-02-08 19:53:03 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-02-08 19:53:03 +0100
commitddc2b61c71264eea4e403b5f1e4ea872bc6da78a (patch)
treef5b3fe53dbd6e925d561c0a134e45bc712169317 /app-crypt/simp_le/simp_le-9999.ebuild
parentcd2763f5f57be45b4ef597417f4845381880a26d (diff)
downloadgentoo-ddc2b61c71264eea4e403b5f1e4ea872bc6da78a.tar.gz
gentoo-ddc2b61c71264eea4e403b5f1e4ea872bc6da78a.tar.xz
app-crypt/simp_le: simple let's encrypt client
Diffstat (limited to 'app-crypt/simp_le/simp_le-9999.ebuild')
-rw-r--r--app-crypt/simp_le/simp_le-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/simp_le/simp_le-9999.ebuild b/app-crypt/simp_le/simp_le-9999.ebuild
new file mode 100644
index 00000000000..6ae12e3e361
--- /dev/null
+++ b/app-crypt/simp_le/simp_le-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/kuba/simp_le.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/kuba/simp_le/archive/v${PV}.tar.gz -> simp_le-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Let's Encrypt Client"
+HOMEPAGE="https://github.com/kuba/simp_le"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ =app-crypt/acme-0.1.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? ( ${RDEPEND} dev-python/pylint[${PYTHON_USEDEP}] dev-python/pep8[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"