summaryrefslogtreecommitdiff
path: root/app-crypt/tc-play
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/tc-play
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/tc-play')
-rw-r--r--app-crypt/tc-play/Manifest1
-rw-r--r--app-crypt/tc-play/metadata.xml13
-rw-r--r--app-crypt/tc-play/tc-play-2.0.ebuild52
3 files changed, 66 insertions, 0 deletions
diff --git a/app-crypt/tc-play/Manifest b/app-crypt/tc-play/Manifest
new file mode 100644
index 00000000000..7a4fcf6d73f
--- /dev/null
+++ b/app-crypt/tc-play/Manifest
@@ -0,0 +1 @@
+DIST tc-play-2.0.tar.gz 1015525 SHA256 0e17890f37e862746364b10bad62bbd9f3e2b2811a24b07df12eff266534e42d SHA512 17408b2a664eb6822c77ede4f38ca67cdf643512014619d830a2c024bb8971811eded4edd65f6398d6112a3b57cd11a5b414357878c817c9cc2aac9d851946d7 WHIRLPOOL 0fc8273debd60f421eecced41ba43bd5fc36c6fd09f48f365755bfe844bf3a425be79ca36ffe3011a01d70b9911da0cfcb0e21571b3af97ec9f8d84af3440806
diff --git a/app-crypt/tc-play/metadata.xml b/app-crypt/tc-play/metadata.xml
new file mode 100644
index 00000000000..add1c176228
--- /dev/null
+++ b/app-crypt/tc-play/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <use>
+ <flag name="openssl">
+ Use openssl crypto backend.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">bwalex/tc-play</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/tc-play/tc-play-2.0.ebuild b/app-crypt/tc-play/tc-play-2.0.ebuild
new file mode 100644
index 00000000000..4d371e2d7ef
--- /dev/null
+++ b/app-crypt/tc-play/tc-play-2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="a free, pretty much fully featured and stable TrueCrypt implementation"
+HOMEPAGE="https://github.com/bwalex/tc-play"
+SRC_URI="https://github.com/bwalex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openssl"
+
+DEPEND="
+ dev-libs/libgpg-error
+ sys-fs/lvm2
+ sys-apps/util-linux
+ dev-libs/libgcrypt:0
+ openssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local backend="gcrypt"
+ use openssl && backend="openssl"
+
+ EXTRA_MAKE_FLAGS=(
+ PBKDF_BACKEND="${backend}"
+ WARNFLAGS=""
+ CC=$(tc-getCC)
+ AR=$(tc-getAR)
+ PREFIX=/usr \
+ LIBDIR=/usr/$(get_libdir)
+ )
+}
+
+src_compile() {
+ emake -f Makefile.classic \
+ tcplay \
+ "${EXTRA_MAKE_FLAGS[@]}"
+}
+
+src_install() {
+ emake -f Makefile.classic \
+ "${EXTRA_MAKE_FLAGS[@]}" \
+ install_program \
+ DESTDIR="${ED}"
+ dodoc README.md
+}