summaryrefslogtreecommitdiff
path: root/app-crypt/tinyca
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/tinyca
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/tinyca')
-rw-r--r--app-crypt/tinyca/Manifest1
-rw-r--r--app-crypt/tinyca/files/tinyca-2.0.7.3-compositefix.patch12
-rw-r--r--app-crypt/tinyca/files/tinyca-2.0.7.5-openssl-1.patch48
-rw-r--r--app-crypt/tinyca/files/tinyca-2.0.7.5-perl-5.18.patch47
-rw-r--r--app-crypt/tinyca/metadata.xml5
-rw-r--r--app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild68
6 files changed, 181 insertions, 0 deletions
diff --git a/app-crypt/tinyca/Manifest b/app-crypt/tinyca/Manifest
new file mode 100644
index 00000000000..ecdfc457c1d
--- /dev/null
+++ b/app-crypt/tinyca/Manifest
@@ -0,0 +1 @@
+DIST tinyca2-0.7.5.tar.bz2 172779 SHA256 dc7d8180bf1db572fa4b08e15ecf8a47fc1c5bfdb55109bf2b3a54f86e5e60b7 SHA512 47df0b995715ad973b12da7d2999ae90f8887549437235b287e1d294331adc8d527bf4435ce1c30df278db8e5f8fc7df29a35d3650d41bfd4d0a0a7c193994aa WHIRLPOOL 5f990529ee503f07d8df0132c1b5834b8353d4908650535adb67ba82f04b1472559dca40ee972e4ce6ac22f31706774c981fc8fc905964df4b837ba6bec1a9be
diff --git a/app-crypt/tinyca/files/tinyca-2.0.7.3-compositefix.patch b/app-crypt/tinyca/files/tinyca-2.0.7.3-compositefix.patch
new file mode 100644
index 00000000000..a074eec2025
--- /dev/null
+++ b/app-crypt/tinyca/files/tinyca-2.0.7.3-compositefix.patch
@@ -0,0 +1,12 @@
+--- tinyca2-0.7.2/./tinyca2.orig 2006-05-28 21:45:03.000000000 +1000
++++ tinyca2-0.7.2/tinyca2 2006-05-28 21:46:38.000000000 +1000
+@@ -87,6 +87,9 @@
+
+ umask(0077);
+
++# https://bugs.gentoo.org/show_bug.cgi?id=78576
++$ENV{XLIB_SKIP_ARGB_VISUALS}= '1';
++
+ # create main object and initialize CA
+ my $gui = GUI->new($init);
+
diff --git a/app-crypt/tinyca/files/tinyca-2.0.7.5-openssl-1.patch b/app-crypt/tinyca/files/tinyca-2.0.7.5-openssl-1.patch
new file mode 100644
index 00000000000..3691d5b9cc9
--- /dev/null
+++ b/app-crypt/tinyca/files/tinyca-2.0.7.5-openssl-1.patch
@@ -0,0 +1,48 @@
+--- a/lib/OpenSSL.pm.orig 2013-03-05 15:57:46.332286060 +0100
++++ b/lib/OpenSSL.pm 2013-03-05 15:57:53.408466038 +0100
+@@ -605,6 +605,8 @@
+ # dirty fix (incompleted) --curly
+ $i = sprintf( "%x", $1);
+ $tmp->{'SERIAL'} = length($i)%2?"0".uc($i):uc($i);
++ } elsif ($_ =~ /^\s*([da-f]{2}:\w{2}:\w{2}:\w{2}:\w{2}:\w{2}:\w{2}:\w{2})\s*$/i) {
++ $tmp->{'SERIAL'} = $1;
+ } elsif ($_ =~ /Signature Algorithm.*: (\w+)/i) {
+ $tmp->{'SIG_ALGORITHM'} = $1;
+ } elsif ($_ =~ /Issuer: (.+)/i) {
+@@ -823,10 +825,10 @@
+ $cmd = "$self->{'bin'} $opts->{'cmd'}";
+ $cmd .= " -config $opts->{'config'}" if(defined($opts->{'config'}));
+ $cmd .= " -inform $opts->{'inform'}";
+- $cmd .= " -out \"$file\"";
+ if($opts->{'outform'} eq 'TEXT') {
+ $cmd .= " -text -noout";
+ } else {
++ $cmd .= " -out \"$file\"";
+ $cmd .= " -outform $opts->{'outform'}";
+ }
+
+@@ -859,13 +861,17 @@
+ }
+ }
+
+- open(IN, $file) || do {
+- my $t = sprintf(_("Can't open file %s: %s"), $file, $!);
+- GUI::HELPERS::print_warning($t);
+- return;
+- };
+- $tmp .= $_ while(<IN>);
+- close(IN);
++ if ($opts->{'outform'} eq 'TEXT') {
++ $tmp = $ext;
++ } else {
++ open(IN, $file) || do {
++ my $t = sprintf(_("Can't open file %s: %s"), $file, $!);
++ GUI::HELPERS::print_warning($t);
++ return;
++ };
++ $tmp .= $_ while(<IN>);
++ close(IN);
++ }
+
+ unlink($file);
+
diff --git a/app-crypt/tinyca/files/tinyca-2.0.7.5-perl-5.18.patch b/app-crypt/tinyca/files/tinyca-2.0.7.5-perl-5.18.patch
new file mode 100644
index 00000000000..39b3a6e29f4
--- /dev/null
+++ b/app-crypt/tinyca/files/tinyca-2.0.7.5-perl-5.18.patch
@@ -0,0 +1,47 @@
+--- tinyca2-0.7.5.orig/lib/GUI.pm 2006-07-25 16:12:00.000000000 -0400
+--- tinyca2-0.7.5/lib/GUI.pm 2006-07-25 16:12:00.000000000 -0400
+@@ -978,7 +978,7 @@
+ $piter = $store->append($root);
+ $store->set($piter, 0 => $t);
+
+- for my $l qw(CN EMAIL O OU C ST L) {
++ for my $l (qw(CN EMAIL O OU C ST L)) {
+ if(defined($parsed->{$l})) {
+ if($l eq "OU") {
+ foreach my $ou (@{$parsed->{'OU'}}) {
+@@ -1003,7 +1003,7 @@
+ $piter = $store->append($root);
+ $store->set($piter, 0 => $t);
+
+- for my $l qw(CN EMAIL O OU C ST L) {
++ for my $l (qw(CN EMAIL O OU C ST L)) {
+ if(defined($parsed->{'ISSUERDN'}->{$l})) {
+ if($l eq "OU") {
+ foreach my $ou (@{$parsed->{'ISSUERDN'}->{'OU'}}) {
+@@ -1029,7 +1029,7 @@
+ $piter = $store->append($root);
+ $store->set($piter, 0 => $t);
+
+- for my $l qw(STATUS NOTBEFORE NOTAFTER) {
++ for my $l (qw(STATUS NOTBEFORE NOTAFTER)) {
+ if(defined($parsed->{$l})) {
+ $citer = $store->append($piter);
+ $store->set($citer,
+@@ -1045,7 +1045,7 @@
+ $store->set($piter, 0 => $t);
+
+
+- for my $l qw(STATUS SERIAL KEYSIZE PK_ALGORITHM SIG_ALGORITHM TYPE) {
++ for my $l (qw(STATUS SERIAL KEYSIZE PK_ALGORITHM SIG_ALGORITHM TYPE)) {
+ if(defined($parsed->{$l})) {
+ $citer = $store->append($piter);
+ $store->set($citer,
+@@ -1060,7 +1060,7 @@
+ $piter = $store->append($root);
+ $store->set($piter, 0 => $t);
+
+- for my $l qw(FINGERPRINTMD5 FINGERPRINTSHA1) {
++ for my $l (qw(FINGERPRINTMD5 FINGERPRINTSHA1)) {
+ if(defined($parsed->{$l})) {
+ $citer = $store->append($piter);
+ $store->set($citer,
diff --git a/app-crypt/tinyca/metadata.xml b/app-crypt/tinyca/metadata.xml
new file mode 100644
index 00000000000..d68fe974c15
--- /dev/null
+++ b/app-crypt/tinyca/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+</pkgmetadata>
diff --git a/app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild b/app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild
new file mode 100644
index 00000000000..6fce7506aa8
--- /dev/null
+++ b/app-crypt/tinyca/tinyca-2.0.7.5-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${PN}${PV/./-}"
+DESCRIPTION="Simple Perl/Tk GUI to manage a small certification authority"
+HOMEPAGE="http://tinyca.sm-zone.net/"
+SRC_URI="http://tinyca.sm-zone.net/${MY_P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+LANGS="en de cs es sv"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="
+ >=dev-libs/openssl-0.9.7e:0=
+ dev-perl/Locale-gettext
+ >=virtual/perl-MIME-Base64-2.12
+ >=dev-perl/gtk2-perl-1.072"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.7.3-compositefix.patch"
+ epatch "${FILESDIR}/${P}-openssl-1.patch"
+ epatch "${FILESDIR}/${P}-perl-5.18.patch"
+ sed -i -e 's:./lib:/usr/share/tinyca/lib:g' \
+ -e 's:./templates:/usr/share/tinyca/templates:g' \
+ -e 's:./locale:/usr/share/locale:g' "${S}/tinyca2" || die
+}
+
+src_compile() {
+ emake -C po
+}
+
+locale_install() {
+ insinto /usr/share/locale/$@/LC_MESSAGES/
+ doins locale/$@/LC_MESSAGES/tinyca2.mo
+}
+
+src_install() {
+ newbin tinyca2 tinyca
+ insinto /usr/share/tinyca/lib
+ doins lib/*.pm
+ insinto /usr/share/tinyca/lib/GUI
+ doins lib/GUI/*.pm
+ insinto /usr/share/tinyca/templates
+ doins templates/*
+ insinto /usr/share/
+ strip-linguas ${LANGS}
+ local l
+ for l in ${LANGS}; do
+ if [ "$l" != "en" ]; then
+ use linguas_$l && locale_install $l
+ fi
+ done
+}