summaryrefslogtreecommitdiff
path: root/app-crypt/tpm-emulator
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-12-07 20:27:42 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-12-11 18:35:37 +0200
commit52c44e18ccdc716c5ef2d8bd969bafc43f6fbca8 (patch)
tree34a32e8321488d59031ecab6fc156a794b60cd8f /app-crypt/tpm-emulator
parenta8776df949978d5f185f1982c5269c1a4d3b226a (diff)
downloadgentoo-52c44e18ccdc716c5ef2d8bd969bafc43f6fbca8.tar.gz
gentoo-52c44e18ccdc716c5ef2d8bd969bafc43f6fbca8.tar.xz
app-crypt/tpm-emulator: allow fallthrough
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=640200 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-crypt/tpm-emulator')
-rw-r--r--app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild b/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
index 8f55dd6e71a..3bd4cc56bd5 100644
--- a/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
+++ b/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
MODULES_OPTIONAL_USE="modules"
-inherit user linux-mod cmake-utils udev
+inherit flag-o-matic user linux-mod cmake-utils udev
MY_P=${P/-/_}
DESCRIPTION="Emulator driver for tpm"
@@ -46,6 +46,7 @@ src_configure() {
local mycmakeargs=(
-DUSE_OPENSSL=$(usex ssl)
)
+ append-cflags -Wno-implicit-fallthrough
cmake-utils_src_configure
# only here we have BUILD_DIR