summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-12-02 20:41:48 -0500
committerVirgil Dupras <vdupras@gentoo.org>2018-12-02 20:41:48 -0500
commit52da679427e9bc308ef95ad6fbfd251ced2b334d (patch)
tree5693c44ca601148a539eb76b6f358c9a2c1f15b2 /app-crypt
parentdb6e9149dd774a315670bbad8c145e0aebecf13d (diff)
downloadgentoo-52da679427e9bc308ef95ad6fbfd251ced2b334d.tar.gz
gentoo-52da679427e9bc308ef95ad6fbfd251ced2b334d.tar.xz
app-crypt/certbot: remove spurious test deps
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/certbot-0.25.1.ebuild11
-rw-r--r--app-crypt/certbot/certbot-0.27.1.ebuild9
-rw-r--r--app-crypt/certbot/certbot-0.28.0.ebuild9
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild9
4 files changed, 5 insertions, 33 deletions
diff --git a/app-crypt/certbot/certbot-0.25.1.ebuild b/app-crypt/certbot/certbot-0.25.1.ebuild
index 862f352ff1c..c509b6fd5e8 100644
--- a/app-crypt/certbot/certbot-0.25.1.ebuild
+++ b/app-crypt/certbot/certbot-0.25.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -38,16 +38,9 @@ RDEPEND="
DEPEND="
${CDEPEND}
test? (
- >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipdb[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
)"
python_test() {
- nosetests -v ${PN} || die
+ pytest -vv ${PN} || die
}
diff --git a/app-crypt/certbot/certbot-0.27.1.ebuild b/app-crypt/certbot/certbot-0.27.1.ebuild
index b0b558ecae0..997ec14b98c 100644
--- a/app-crypt/certbot/certbot-0.27.1.ebuild
+++ b/app-crypt/certbot/certbot-0.27.1.ebuild
@@ -38,16 +38,9 @@ RDEPEND="
DEPEND="
${CDEPEND}
test? (
- >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipdb[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
)"
python_test() {
- nosetests -v ${PN} || die
+ pytest -vv ${PN} || die
}
diff --git a/app-crypt/certbot/certbot-0.28.0.ebuild b/app-crypt/certbot/certbot-0.28.0.ebuild
index dd686122dfa..bb543bdc2d0 100644
--- a/app-crypt/certbot/certbot-0.28.0.ebuild
+++ b/app-crypt/certbot/certbot-0.28.0.ebuild
@@ -38,16 +38,9 @@ RDEPEND="
DEPEND="
${CDEPEND}
test? (
- >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipdb[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
)"
python_test() {
- nosetests -v ${PN} || die
+ pytest -vv ${PN} || die
}
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index dd686122dfa..bb543bdc2d0 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -38,16 +38,9 @@ RDEPEND="
DEPEND="
${CDEPEND}
test? (
- >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipdb[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
)"
python_test() {
- nosetests -v ${PN} || die
+ pytest -vv ${PN} || die
}