summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-03 05:05:17 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-03 05:05:17 -0400
commit798e38393e0de024ff98007c1597e060c2876247 (patch)
tree43c82a6255eb34af3e7447aee284c5ca4348212f /app-crypt
parent363e9571241374a09a842d07237a2cd87dd5791a (diff)
downloadgentoo-798e38393e0de024ff98007c1597e060c2876247.tar.gz
gentoo-798e38393e0de024ff98007c1597e060c2876247.tar.xz
app-crypt/efitools: add libressl support
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/efitools/efitools-1.4.2-r1.ebuild10
-rw-r--r--app-crypt/efitools/efitools-1.7.0.ebuild8
2 files changed, 11 insertions, 7 deletions
diff --git a/app-crypt/efitools/efitools-1.4.2-r1.ebuild b/app-crypt/efitools/efitools-1.4.2-r1.ebuild
index dabedc534ab..f231f2c0f4b 100644
--- a/app-crypt/efitools/efitools-1.4.2-r1.ebuild
+++ b/app-crypt/efitools/efitools-1.4.2-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
DESCRIPTION="Tools for manipulating UEFI secure boot platforms"
HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jejb/efitools.git"
@@ -11,9 +11,11 @@ SRC_URI="http://blog.hansenpartnership.com/wp-uploads/2013/efitools-${PV}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="libressl"
-RDEPEND="dev-libs/openssl
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
sys-apps/util-linux"
DEPEND="${RDEPEND}
sys-apps/help2man
diff --git a/app-crypt/efitools/efitools-1.7.0.ebuild b/app-crypt/efitools/efitools-1.7.0.ebuild
index 4395a3d2810..d54950bc975 100644
--- a/app-crypt/efitools/efitools-1.7.0.ebuild
+++ b/app-crypt/efitools/efitools-1.7.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit git-r3
DESCRIPTION="Tools for manipulating UEFI secure boot platforms"
@@ -15,9 +15,11 @@ EGIT_COMMIT="v1.7.0"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="libressl"
-RDEPEND="dev-libs/openssl
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
sys-apps/util-linux"
DEPEND="${RDEPEND}
sys-apps/help2man