summaryrefslogtreecommitdiff
path: root/app-dicts/gnome-dictionary/gnome-dictionary-3.18.1.ebuild
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-01-30 12:10:19 +0100
committerPacho Ramos <pacho@gentoo.org>2016-01-30 13:23:19 +0100
commit762828df7a830e6157a2b730163a5a276c76b534 (patch)
treeffa0e1e956c08b21b065b353e239de52b2f002d7 /app-dicts/gnome-dictionary/gnome-dictionary-3.18.1.ebuild
parent3a5b3531d5e79c82b409b326323eabc9b54fdb98 (diff)
downloadgentoo-762828df7a830e6157a2b730163a5a276c76b534.tar.gz
gentoo-762828df7a830e6157a2b730163a5a276c76b534.tar.xz
app-dicts/gnome-dictionary: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-dicts/gnome-dictionary/gnome-dictionary-3.18.1.ebuild')
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-3.18.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-3.18.1.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-3.18.1.ebuild
new file mode 100644
index 00000000000..148b84314a6
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-3.18.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Dictionary utility for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Dictionary"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0/9" # subslot = suffix of libgdict-1.0.so
+IUSE="+introspection ipv6"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39:2[dbus]
+ x11-libs/cairo:=
+ >=x11-libs/gtk+-3.14:3
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ dev-util/itstool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable ipv6)
+}