summaryrefslogtreecommitdiff
path: root/app-dicts
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-25 17:17:06 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-25 17:17:06 -0400
commitf7de107981d48e07af73253190ea994565c0c9c7 (patch)
tree92e78276892e517047a0a87f1a7822c4e4c0ef97 /app-dicts
parent581d19adeff410015bb678dbebadb12b49632fde (diff)
downloadgentoo-f7de107981d48e07af73253190ea994565c0c9c7.tar.gz
gentoo-f7de107981d48e07af73253190ea994565c0c9c7.tar.xz
app-dicts/myspell-eo: new EAPI=6 revision.
This new revision serves two purposes. First, it will eliminate an EAPI=4 ebuild; and second, it sets the distfile name to something that isn't likely to collide. Gentoo-Bug: 619840 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-eo/Manifest1
-rw-r--r--app-dicts/myspell-eo/myspell-eo-1.0-r1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-dicts/myspell-eo/Manifest b/app-dicts/myspell-eo/Manifest
index d76994d4190..0344da9fb59 100644
--- a/app-dicts/myspell-eo/Manifest
+++ b/app-dicts/myspell-eo/Manifest
@@ -1 +1,2 @@
DIST 1.0-dev.oxt 186411 SHA256 dc07976e7ee03f556a0c2a0daaceca8fcccbaa823e6a9e31a8d709cb58666576 SHA512 164ac71523d688c4f32ca14b44c87a15d15eaad11e553c44e2ebc75e4d5ffa98b96663059a8d57b0c18556f5fb5c95d55a4b5c16e89b3b8c4f2116e2cdac0f1c WHIRLPOOL 99caf55085895ac81e9e9392d42ab99a252bd60346766c95f3cc7b15abd000d93a451d31f6a71a2cccd778897ecf5b75bb872bd51c21ad838d984044bca9be97
+DIST myspell-eo-1.0.oxt 186407 SHA256 70d65bb07db99aaa1b0db50862057a712b454c8f0211c6a5353cdc48140eff91 SHA512 b5cf3a14672fb0e6b810e5b4d811f430b3c3cc38cf09a0083b7e26471597c6df055242349a2a239607621301f71527e8bf225dc03de727c5863e7b7b1c821824 WHIRLPOOL 64ded4ee18c3b9bb2e3796c16c71fa04e32303579e2a1c652b697a1281a1de35912317987da9cbabe791072eac44ee0f89b6dd18289039af6ec9d9002a51338a
diff --git a/app-dicts/myspell-eo/myspell-eo-1.0-r1.ebuild b/app-dicts/myspell-eo/myspell-eo-1.0-r1.ebuild
new file mode 100644
index 00000000000..35b87420abf
--- /dev/null
+++ b/app-dicts/myspell-eo/myspell-eo-1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MYSPELL_DICT=(
+ "eo_l3.aff"
+ "eo_l3.dic"
+)
+
+MYSPELL_HYPH=(
+)
+
+MYSPELL_THES=(
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Esperanto dictionaries for myspell/hunspell"
+HOMEPAGE="http://nlp.fi.muni.cz/projekty/esperanto_spell_checker/"
+SRC_URI="mirror://sourceforge/aoo-extensions/3377/1/${PV}-dev.oxt -> ${P}.oxt"
+
+LICENSE="GPL-2 LGPL-3 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ default
+
+ # move the dicts for nicer name
+ mv literumilo.aff eo_l3.aff || die
+ mv literumilo.dic eo_l3.dic || die
+}