summaryrefslogtreecommitdiff
path: root/app-doc/xmltoman
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-08 19:34:13 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-08 19:35:28 +0100
commita42b373d911b7a822baa661ad1b60f7936fc26ce (patch)
treebddef2eec391e816a7af1220892a01e438d91e7b /app-doc/xmltoman
parent3f9c1ec131d9f546f9e16557c0c594c6fd0352d4 (diff)
downloadgentoo-a42b373d911b7a822baa661ad1b60f7936fc26ce.tar.gz
gentoo-a42b373d911b7a822baa661ad1b60f7936fc26ce.tar.xz
app-doc/xmltoman: Fix non-portable 'install' phase, bump to EAPI=6
Closes: https://bugs.gentoo.org/649942
Diffstat (limited to 'app-doc/xmltoman')
-rw-r--r--app-doc/xmltoman/xmltoman-0.4-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-doc/xmltoman/xmltoman-0.4-r1.ebuild b/app-doc/xmltoman/xmltoman-0.4-r1.ebuild
new file mode 100644
index 00000000000..6ecf6a41114
--- /dev/null
+++ b/app-doc/xmltoman/xmltoman-0.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Simple scripts for converting xml to groff or html"
+HOMEPAGE="https://sourceforge.net/projects/xmltoman/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/XML-Parser"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ # 'make install' requires GNU install, upstream is dead and carrying
+ # a patch is more space than redoing it here
+ dobin xmltoman xmlmantohtml
+ insinto /usr/share/xmltoman
+ doins xmltoman.{css,dtd,xsl}
+ dodoc README
+ doman xmltoman.1 xmlmantohtml.1
+}