summaryrefslogtreecommitdiff
path: root/app-doc/zeal/zeal-0.4.0.ebuild
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-09-16 22:38:08 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-16 22:38:21 +0200
commite77f88c5803cbd0f347340b90ea5c6fcaf3ab0f1 (patch)
tree9d131be1c48bd10a9d95176991b73f16d26e27d8 /app-doc/zeal/zeal-0.4.0.ebuild
parentb201bf11b1c1b7873b900be8b0920849903fed65 (diff)
downloadgentoo-e77f88c5803cbd0f347340b90ea5c6fcaf3ab0f1.tar.gz
gentoo-e77f88c5803cbd0f347340b90ea5c6fcaf3ab0f1.tar.xz
app-doc/zeal: version bump.
Gentoo-Bug: https://bugs.gentoo.org/631040 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-doc/zeal/zeal-0.4.0.ebuild')
-rw-r--r--app-doc/zeal/zeal-0.4.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-doc/zeal/zeal-0.4.0.ebuild b/app-doc/zeal/zeal-0.4.0.ebuild
new file mode 100644
index 00000000000..b96162ca7d3
--- /dev/null
+++ b/app-doc/zeal/zeal-0.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils gnome2-utils fdo-mime
+
+DESCRIPTION="Offline documentation browser inspired by Dash"
+HOMEPAGE="https://zealdocs.org/"
+SRC_URI="https://github.com/zealdocs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-arch/libarchive
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=x11-libs/xcb-util-keysyms-0.3.9
+"
+
+RDEPEND="
+ ${DEPEND}
+ x11-themes/hicolor-icon-theme
+"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}