summaryrefslogtreecommitdiff
path: root/app-editors/ghostwriter
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2018-12-15 15:42:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-16 15:24:41 +0100
commitb2be7e64f76ae544c751a6e33638fd910a7c9633 (patch)
tree2da5b06cccb2058255b74d195beb8f0871fcd617 /app-editors/ghostwriter
parent1e8f2bb266d414f023e46c0fe5362fd128b7a50a (diff)
downloadgentoo-b2be7e64f76ae544c751a6e33638fd910a7c9633.tar.gz
gentoo-b2be7e64f76ae544c751a6e33638fd910a7c9633.tar.xz
app-editors/ghostwriter: verbump to 1.7.4
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10646 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/ghostwriter')
-rw-r--r--app-editors/ghostwriter/Manifest1
-rw-r--r--app-editors/ghostwriter/ghostwriter-1.7.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-editors/ghostwriter/Manifest b/app-editors/ghostwriter/Manifest
index 443e7970811..0bd394321c3 100644
--- a/app-editors/ghostwriter/Manifest
+++ b/app-editors/ghostwriter/Manifest
@@ -1,2 +1,3 @@
DIST ghostwriter-1.5.0.tar.gz 620301 BLAKE2B 07af6c6b176f15a7b6bee0594936a346160783c553dfd91cd69bde3975ada5c125920c1029ab19aee21c89576c6fab311f7a893447c457ff5a174149e57f67bb SHA512 4b6e1430342069b224f7aece30d5a592a43e9f702cb93fc073fded741771ea74b8478203aeaecdabb791aa7ddd8055d5c36346518adc7dd19b61e5f2e2cbe219
DIST ghostwriter-1.7.3.tar.gz 673328 BLAKE2B 5304f5218da5fe535dea1ed9d43c4358212d9b1025dcc7102a77852c833ba1301d59539df4e2a44fd8a46abe7dfbdc7c6ab490d3f9e8ed5f7b4571b604c3bbb6 SHA512 a6f7e64078bdb3ecd9ea48ead8e96811e62215292a1c4a269f23efb6c0403c62fb0aab3e1303397b08036a7f3507d04a8eb8c14baafd78f64fea20805bb24a5a
+DIST ghostwriter-1.7.4.tar.gz 1195162 BLAKE2B 6339161b73b6e8cf9fce37da5133416512a61289189fb3f574af96753e62e8e364d610dd277542bd18b4ec44692dc149d4b3d5a6cd89894536d4dc898994c667 SHA512 b09e0f8152cd8bdd4465f20d94134ea6ef840b4ccd6d9f75bce8452917d98adc89093c661ecde0400fba7d68f832633c8fe0b19a1607ce79e3f400caa573da8f
diff --git a/app-editors/ghostwriter/ghostwriter-1.7.4.ebuild b/app-editors/ghostwriter/ghostwriter-1.7.4.ebuild
new file mode 100644
index 00000000000..188e72be1f1
--- /dev/null
+++ b/app-editors/ghostwriter/ghostwriter-1.7.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
+HOMEPAGE="https://wereturtle.github.io/ghostwriter/"
+SRC_URI="https://github.com/wereturtle/ghostwriter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ app-text/hunspell
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+"
+
+DOCS=( CREDITS.md README.md )
+
+src_prepare() {
+ default
+
+ sed -i -e "/^VERSION =/s/\$.*/${PV}/" ghostwriter.pro || die "failed to override version"
+}
+
+src_configure() {
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}