summaryrefslogtreecommitdiff
path: root/app-editors/ne
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/ne
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/ne')
-rw-r--r--app-editors/ne/Manifest2
-rw-r--r--app-editors/ne/metadata.xml10
-rw-r--r--app-editors/ne/ne-2.5.ebuild53
-rw-r--r--app-editors/ne/ne-3.0.1.ebuild54
4 files changed, 119 insertions, 0 deletions
diff --git a/app-editors/ne/Manifest b/app-editors/ne/Manifest
new file mode 100644
index 00000000000..0d0cab3a3d7
--- /dev/null
+++ b/app-editors/ne/Manifest
@@ -0,0 +1,2 @@
+DIST ne-2.5.tar.gz 1106020 SHA256 e11581d84ff855c3fab5c2bddc3a4633a3b28bb2ce89508e4568d3c3fc929f58 SHA512 e93b5da33565c8ef0b3263083bacec46f1867f78950e0bed940b2f18d14eb42bfa6323130eabe0f793f427a5bea5e04df6ef8e4a0276a883822b0842cbd8b5ed WHIRLPOOL 8bf3f9bd0d735bfef656713e9485a74f901c212396a691ee7faf01f4afa2918f03ec053d289e7311a7bae8b3a7d44c928cb109fefa6b1df581ae8da9c6a3d453
+DIST ne-3.0.1.tar.gz 1193311 SHA256 92b646dd2ba64052e62deaa4239373821050a03e1b7d09d203ce04f2adfbd0e4 SHA512 3750140a49c7424e92e509137d5f31d305b81d41939a2578f6a26065216ebd1aa444b0e8d7e79dd09cc525e1055cda4d756f21ec810f860063d2eec861ea8273 WHIRLPOOL e0630f7e077400393ee5734989327369f2d646c88a32313f193b34e7f44d7962b368a5deb5876cfe997e34295078b44fba1672cfb257ef3dc08a8597a5708a5b
diff --git a/app-editors/ne/metadata.xml b/app-editors/ne/metadata.xml
new file mode 100644
index 00000000000..f3e7ae06bec
--- /dev/null
+++ b/app-editors/ne/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<use>
+<flag name='tinfo'>Link against libtinfo from sys-libs/ncurses</flag>
+</use>
+</pkgmetadata>
diff --git a/app-editors/ne/ne-2.5.ebuild b/app-editors/ne/ne-2.5.ebuild
new file mode 100644
index 00000000000..de1216898f3
--- /dev/null
+++ b/app-editors/ne/ne-2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="the nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="http://ne.di.unimi.it/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=tinfo
+
+DEPEND="
+ >=sys-libs/ncurses-5.2[tinfo?]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+
+src_prepare() {
+ sed -i -e 's/-O3//' src/makefile || die
+}
+
+src_configure() {
+ if use tinfo; then
+ sed -i -e 's|-lcurses|-ltinfo|g' src/makefile || die
+ else
+ sed -i -e 's|-lcurses|-lncurses|g' src/makefile || die
+ fi
+}
+
+src_compile() {
+ emake -C src CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/ne" \
+ OPTS="${CFLAGS}" \
+ ne || die
+}
+
+src_install() {
+ dobin src/ne
+
+ insinto /usr/share/ne/syntax
+ doins syntax/*.jsf
+
+ doman doc/ne.1
+ dohtml -r doc/html/.
+ dodoc CHANGES README doc/*.{txt,pdf,texinfo} doc/default.*
+}
diff --git a/app-editors/ne/ne-3.0.1.ebuild b/app-editors/ne/ne-3.0.1.ebuild
new file mode 100644
index 00000000000..505846d5c08
--- /dev/null
+++ b/app-editors/ne/ne-3.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="the nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="http://ne.di.unimi.it/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=tinfo
+
+DEPEND="
+ >=sys-libs/ncurses-5.2[tinfo?]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+
+src_prepare() {
+ sed -i -e 's/-O3//' src/makefile || die
+}
+
+src_configure() {
+ if use tinfo; then
+ sed -i -e 's|-lcurses|-ltinfo|g' src/makefile || die
+ else
+ sed -i -e 's|-lcurses|-lncurses|g' src/makefile || die
+ fi
+}
+
+src_compile() {
+ append-cflags -std=c11
+ emake -C src CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/ne" \
+ OPTS="${CFLAGS}" \
+ ne || die
+}
+
+src_install() {
+ dobin src/ne
+
+ insinto /usr/share/ne/syntax
+ doins syntax/*.jsf
+
+ doman doc/ne.1
+ dohtml -r doc/html/.
+ dodoc CHANGES README.md NEWS doc/*.{txt,pdf,texinfo} doc/default.*
+}