summaryrefslogtreecommitdiff
path: root/app-editors/sublime-text
diff options
context:
space:
mode:
authorGeorgy Yakovlev <ya@sysdump.net>2018-05-14 10:44:06 -0700
committerAmy Liffey <amynka@gentoo.org>2018-05-22 13:50:34 +0200
commitc8db93643969f86705699322499b7de072ce34e9 (patch)
tree998b68a11ca32545372852ca29ea2203d72ef11a /app-editors/sublime-text
parent4d7dc353f4a19ee0fb8de5513039103c8c1a1783 (diff)
downloadgentoo-c8db93643969f86705699322499b7de072ce34e9.tar.gz
gentoo-c8db93643969f86705699322499b7de072ce34e9.tar.xz
app-editors/sublime-text: version bump to 3176
Acked-by: David Seifert <soap@gentoo.org> Closes: https://bugs.gentoo.org/655236 Closes: https://github.com/gentoo/gentoo/pull/8409 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'app-editors/sublime-text')
-rw-r--r--app-editors/sublime-text/Manifest2
-rw-r--r--app-editors/sublime-text/sublime-text-3_p3176.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/app-editors/sublime-text/Manifest b/app-editors/sublime-text/Manifest
index e0dcb8faeed..09174baba17 100644
--- a/app-editors/sublime-text/Manifest
+++ b/app-editors/sublime-text/Manifest
@@ -1,2 +1,4 @@
DIST sublime_text_3_build_3143_x32.tar.bz2 9847438 BLAKE2B bca62736e3dbaae5aa5318af5aca4c78c5abff1189a58b354205351f21ba1caa8a6b479e9a7e01fdb4a56dec68d50e0e43522918b461463cdada7e6dbda6441c SHA512 471716815a171f786ad5f12b743ec3c17dcde2fc165522e523d338c9184af7789095e2de41e89d0c4b0dc58bfe409f116662016e7014c528650ce074c101084b
DIST sublime_text_3_build_3143_x64.tar.bz2 9857381 BLAKE2B bf69810574eda5bb3afaa82dcbf8b68f9bef1db19af2382e0ee4b93cb87f08caa3f7bdc754419284b3902e0e715a97d211adcd234f35d8038071818368b3fb54 SHA512 db6375cbcaf1cb6e1d583aa043abeaeecf0236e1d2e23b965b6c2dd616ec2277d73786d2a9c273329c1a94890edc7ddce1551292b5170dc5b558cd7246c5093f
+DIST sublime_text_3_build_3176_x32.tar.bz2 10352060 BLAKE2B 97d6e7bcc838ecac53ffa68cc3d355b01d06ea1903fd92b9894f27cf402d0506728be69f27d91dccbcba1bab876f94fd619bcf4877a9d935fb5517e91d2be4ac SHA512 640920a92995aac4af711cb4eb58d142d1afe2cbcbc485a111bc407ce464e81b984cd2110074072cc3805ed8656a4a60acce6f1a014f8a3f27f1b340222b0071
+DIST sublime_text_3_build_3176_x64.tar.bz2 10314226 BLAKE2B 98b0cda71b8a859614a1a6510afa073ca1aae6b9ac5d4b6db259723e8aa057a8b2bf22a0d26f0b6ccce31f39e047293ed84c4a63b8739a6d08c05af5791967bd SHA512 c37bd0d6d7fbbe2757f4244ae2803086d5fe1e25b32a1dd2de4241dc55f66f7c4588f3f9d56059c9d0ef7fe2ae69e76005f16dad60060f38fe10b92fd8eda969
diff --git a/app-editors/sublime-text/sublime-text-3_p3176.ebuild b/app-editors/sublime-text/sublime-text-3_p3176.ebuild
new file mode 100644
index 00000000000..89e271833a0
--- /dev/null
+++ b/app-editors/sublime-text/sublime-text-3_p3176.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils
+
+# get the major version from PV
+MV=${PV:0:1}
+MY_PV=${PV#*_p}
+
+DESCRIPTION="Sophisticated text editor for code, markup and prose"
+HOMEPAGE="https://www.sublimetext.com"
+SRC_URI="
+ amd64? ( https://download.sublimetext.com/sublime_text_${MV}_build_${MY_PV}_x64.tar.bz2 )
+ x86? ( https://download.sublimetext.com/sublime_text_${MV}_build_${MY_PV}_x32.tar.bz2 )"
+
+LICENSE="Sublime"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ dbus? ( sys-apps/dbus )"
+
+QA_PREBUILT="*"
+S="${WORKDIR}/sublime_text_${MV}"
+
+# Sublime bundles the kitchen sink, which includes python and other assorted
+# modules. Do not try to unbundle these because you are guaranteed to fail.
+
+src_install() {
+ insinto /opt/${PN}${MV}
+ doins -r Packages Icon
+ doins changelog.txt sublime_plugin.py sublime.py python3.3.zip
+
+ exeinto /opt/${PN}${MV}
+ doexe crash_reporter plugin_host sublime_text
+ dosym ../../opt/${PN}${MV}/sublime_text /usr/bin/subl
+
+ local size
+ for size in 32 48 128 256; do
+ dosym ../../../../../../opt/${PN}${MV}/Icon/${size}x${size}/sublime-text.png \
+ /usr/share/icons/hicolor/${size}x${size}/apps/subl.png
+ done
+
+ make_desktop_entry "subl" "Sublime Text ${MV}" "subl" \
+ "TextEditor;IDE;Development" "StartupNotify=true"
+
+ # needed to get WM_CLASS lookup right
+ mv "${ED%/}"/usr/share/applications/subl{-sublime-text,}.desktop || die
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}