summaryrefslogtreecommitdiff
path: root/app-editors/vim
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-16 23:57:16 -0400
committerTim Harder <radhermit@gentoo.org>2016-03-16 23:57:16 -0400
commitd2018f09204f3da8cd103943e15344d4e5ed6de3 (patch)
treee6dd52b4bc4f1da076a215ca91f0a37cec2907ce /app-editors/vim
parentf504afcac89ef394347d06ebfc72cc39dd4551e3 (diff)
downloadgentoo-d2018f09204f3da8cd103943e15344d4e5ed6de3.tar.gz
gentoo-d2018f09204f3da8cd103943e15344d4e5ed6de3.tar.xz
app-editors/vim: drop unnecessary test hacks
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/vim-7.4.1583.ebuild14
-rw-r--r--app-editors/vim/vim-9999.ebuild16
2 files changed, 3 insertions, 27 deletions
diff --git a/app-editors/vim/vim-7.4.1583.ebuild b/app-editors/vim/vim-7.4.1583.ebuild
index d0e5706af1c..d711d5e20a5 100644
--- a/app-editors/vim/vim-7.4.1583.ebuild
+++ b/app-editors/vim/vim-7.4.1583.ebuild
@@ -271,19 +271,7 @@ src_test() {
# Don't let vim talk to X
unset DISPLAY
- # We've got to call make test from within testdir, since the Makefiles
- # don't pass through our VIMPROG argument
- cd "${S}"/src/testdir
-
- # Test 49 won't work inside a portage environment
- einfo "Test 49 isn't sandbox-friendly, so it will be skipped."
- sed -i 's~test49.out~~g' Makefile
-
- # We don't want to rebuild vim before running the tests
- sed -i 's,: \$(VIMPROG),: ,' Makefile
-
- # Don't try to do the additional GUI test
- emake -j1 VIMPROG=../vim nongui
+ emake -j1 -C src/testdir nongui
}
# Make convenience symlinks, hopefully without stepping on toes. Some
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index d0e5706af1c..09e7b118598 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -34,7 +34,7 @@ REQUIRED_USE="
RDEPEND="
>=app-eselect/eselect-vi-1.1
- >=sys-libs/ncurses-5.2-r2:=
+ >=sys-libs/ncurses-5.2-r2:0=
nls? ( virtual/libintl )
acl? ( kernel_linux? ( sys-apps/acl ) )
cscope? ( dev-util/cscope )
@@ -271,19 +271,7 @@ src_test() {
# Don't let vim talk to X
unset DISPLAY
- # We've got to call make test from within testdir, since the Makefiles
- # don't pass through our VIMPROG argument
- cd "${S}"/src/testdir
-
- # Test 49 won't work inside a portage environment
- einfo "Test 49 isn't sandbox-friendly, so it will be skipped."
- sed -i 's~test49.out~~g' Makefile
-
- # We don't want to rebuild vim before running the tests
- sed -i 's,: \$(VIMPROG),: ,' Makefile
-
- # Don't try to do the additional GUI test
- emake -j1 VIMPROG=../vim nongui
+ emake -j1 -C src/testdir nongui
}
# Make convenience symlinks, hopefully without stepping on toes. Some