summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-26 14:58:01 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-26 15:20:28 +0100
commit6e328be86018977252bf2361f50b2890ac2dd0f5 (patch)
tree2d345f2537841e8b1be8a0805875768b80b47197 /app-editors
parentd156a6deb35e8cc56c6ae5624f85924fbf018b47 (diff)
downloadgentoo-6e328be86018977252bf2361f50b2890ac2dd0f5.tar.gz
gentoo-6e328be86018977252bf2361f50b2890ac2dd0f5.tar.xz
app-editors/latexila: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/latexila/Manifest1
-rw-r--r--app-editors/latexila/latexila-3.18.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-editors/latexila/Manifest b/app-editors/latexila/Manifest
index 651e7b71966..47bc4511e65 100644
--- a/app-editors/latexila/Manifest
+++ b/app-editors/latexila/Manifest
@@ -1,2 +1,3 @@
DIST latexila-3.16.2.tar.xz 1058776 SHA256 5ad20a2acdb8c93dea5aa175a219e62efe5f4a7ffb67bc52ff6faf0c6f42bad3 SHA512 d9d5c90374d5aa9b2599f90565dde9da1c4dc7713b7be8ffbfac71b5797124142ef46811660f14edfd278ec9d3f3b6b0c56ef325201fb85caf3b7322577e40fc WHIRLPOOL 3fde6abc4979dd9a40cc019e30c8b0e0c55c97fa3a4670d073d1ca6f662342b54923ea263246a169e8944fa3aaba358d6881629e20c6e949b1287e9328c1cdc6
DIST latexila-3.18.1.tar.xz 1092768 SHA256 edfd95f321dfff31fb094c243c358cb78d19904164b9ef4fb37c021113044d0a SHA512 4123cbe4b6df7b493767abbe75ed43e025b640a869a61abec29715f40a3619433bc8300be6a06c8ec5c252215a6b05623d4b7a7f55d7eabbafa6f0ca19a26f92 WHIRLPOOL e1612ba477bef16aaee9f2173f29963c7dab3c0496082fe308ee2bed22b1a6cf9b480f1df1d259a774b593f3c58976de6bc0c3d6757941254abb1a5de067ddb6
+DIST latexila-3.18.2.tar.xz 1094728 SHA256 4bb584ec2c8d2ff8ee91e533ad7cf298f68b4a17c18b5663ea38482095c8773a SHA512 98d927e65c26c883e9f46097c204d612ad7815f1f2ebf73194f56f90ff63ce6e51780e6b7b8f7d5d7c303b52f4dfca3e891f61242fd81ce5898dfef90e15c1b6 WHIRLPOOL fae82e1be3cdee1b67a8ef1cf16d892639bd55b0a485136b4d40ef174bd08921a207c0360a17a85a924d362cd25b437d69dc91c3dac6c973bf6f4d940d7ca775
diff --git a/app-editors/latexila/latexila-3.18.2.ebuild b/app-editors/latexila/latexila-3.18.2.ebuild
new file mode 100644
index 00000000000..eaa43319784
--- /dev/null
+++ b/app-editors/latexila/latexila-3.18.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/LaTeXila"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection +latexmk rubber"
+
+# gspell-0.1 is required for this cycle
+# https://git.gnome.org/browse/latexila/commit/?h=gnome-3-18&id=fd6b77796e304cfb9e31844cf24432d3b2cb6043
+COMMON_DEPEND="$(vala_depend)
+ app-text/enchant
+ =app-text/gspell-0.1*
+ >=dev-libs/glib-2.40:2[dbus]
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.14:3
+ >=x11-libs/gtksourceview-3.18:3.0
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libX11
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ DOCS="AUTHORS HACKING NEWS README"
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection)
+}