summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-04-16 15:34:58 -0500
committerTim Harder <radhermit@gentoo.org>2019-04-16 15:36:14 -0500
commitae4b8e27f02ef70cbc5eee9019a9d990d2acb803 (patch)
tree98827592d38c64f36310586fbddebf06adf87284 /app-editors
parentb63dfb32fe20a08e12a665ebb4e51a5f6d831a14 (diff)
downloadgentoo-ae4b8e27f02ef70cbc5eee9019a9d990d2acb803.tar.gz
gentoo-ae4b8e27f02ef70cbc5eee9019a9d990d2acb803.tar.xz
app-editors/vim: fix USE=minimal build
Closes: https://bugs.gentoo.org/683454 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/vim-8.1.1155.ebuild4
-rw-r--r--app-editors/vim/vim-9999.ebuild4
2 files changed, 2 insertions, 6 deletions
diff --git a/app-editors/vim/vim-8.1.1155.ebuild b/app-editors/vim/vim-8.1.1155.ebuild
index d5c9d74833a..8701b63c9a1 100644
--- a/app-editors/vim/vim-8.1.1155.ebuild
+++ b/app-editors/vim/vim-8.1.1155.ebuild
@@ -143,7 +143,7 @@ src_prepare() {
}
src_configure() {
- local myconf=()
+ local myconf=( --enable-multibyte )
# Fix bug 37354: Disallow -funroll-all-loops on amd64
# Bug 57859 suggests that we want to do this for all archs
@@ -175,7 +175,6 @@ src_configure() {
myconf=(
--with-features=tiny
--disable-nls
- --disable-multibyte
--disable-acl
--enable-gui=no
--without-x
@@ -194,7 +193,6 @@ src_configure() {
myconf=(
--with-features=huge
- --enable-multibyte
$(use_enable acl)
$(use_enable cscope)
$(use_enable gpm)
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index d5c9d74833a..8701b63c9a1 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -143,7 +143,7 @@ src_prepare() {
}
src_configure() {
- local myconf=()
+ local myconf=( --enable-multibyte )
# Fix bug 37354: Disallow -funroll-all-loops on amd64
# Bug 57859 suggests that we want to do this for all archs
@@ -175,7 +175,6 @@ src_configure() {
myconf=(
--with-features=tiny
--disable-nls
- --disable-multibyte
--disable-acl
--enable-gui=no
--without-x
@@ -194,7 +193,6 @@ src_configure() {
myconf=(
--with-features=huge
- --enable-multibyte
$(use_enable acl)
$(use_enable cscope)
$(use_enable gpm)